Why am I getting an error when I try to download a plug in from within my site?

I have downloaded the WPMU DEV plugin onto my site but I get an error anytime I try to download a specific plugin. It will not work if I do this directly from your site, even though my site shows up as a download option.

Everything worked great on the first site I used WPMU DEV on. What have I done wrong? HELP.

Thank you!