Why are blog posts showing up on my home page?

Previously when I used the studio theme blog post never showed up on the front page. Also, I set a “Blog Posts” page and used the blog news template and they it just shows the same front page. weird. Help!!

  • growingup
    • Flash Drive

    I fixed the blog template part. but, the posts are still showing up on my home page which they shouldn’t be. Just don’t set a blog posts page under setttings>>reading and the template will work.

    But, as for the homepage I’m clueless.

  • Timothy
    • Chief Pigeon

    Just don't set a blog posts page under setttings>>reading and the template will work.

    Ya if you set up the reading settings it changes how the front page of a theme normally works.

    For the comments, they show because your using a post for the home page. You can turn off the comments for that post by editing the article options. Screen attached.

    Thanks.

  • growingup
    • Flash Drive

    When I inspect the element it’s showing this code:

    <div class="author-box">
    <div class="post-content">

    When I removed this code the post disappears. The problem is I have no clue what file this is. I’ve tried to look at it in the file manager on the server I can find a file associated with the homepage that has this code in it.

  • Timothy
    • Chief Pigeon

    If you have a direct link then I could propose some CSS to remove it totally if you wish, but that would affect other posts as well.

    You could edit the theme though to do a conditional statement around the comment area like:

    if (!is_home()){
    DO COMMENT CODE;
    }

    Hope this helps.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.