Why are some pages being protected from subscribers, but unprotected from visitors? Other...

I am having an issue with pages that should be available to all subscribers and visitors (http://virtual.podcastmovement.com/contact-us/) only being available to visitors. I have not tried to protect it anywhere.

How do I fix?

Also, it looks like my one time use codes are not disappearing. How do I fix?

  • Dan
    • New Recruit

    Fixed my own problem on the pages being blocked. Had a positive on one level and matching negative on the other, but found out a negative on the other is all I need.

    Still need to know how to make sure the one time use codes disappear...

  • Michael Bissett
    • Recruit

    Hey @Dan, hope you're doing well today, and welcome to WPMU DEV! :slight_smile:

    Glad to hear you were able to get the access level rules sorted, but in regards to those one time use codes, could you elaborate on that (e.g. what are you using to generate those, where can I see one)?

    Please advise,
    Michael

    • Dan
      • New Recruit

      You guys have access to my backend.

      I used their email address as the invite codes, and put them one per line in the "extras" tab.

      Some people have registered using their "code", but their "code" is still on the available list, even though I've checked the option for it to be removed.

  • Dan
    • New Recruit

    It looks to be hit or miss. Some of them are being removed, some are not.

    Also, we are getting about 10% of people whose original invite codes are not working, although entered properly in the backend, but when I create a new one for them, it works.

    Any ideas on these two issues?

  • Michael Bissett
    • Recruit

    Hey @Dan,

    Hmm, this is puzzling one. I've tried testing with a few invite codes of my own inside a test install of mine (they were email addresses, just like the majority of your codes are), and each one was removed after it was used.

    On both of the issues you mentioned in your last comment, I'm curious, do you notice a pattern here (e.g. an email address with a certain extension isn't disappearing)?

    Focusing particularly on this:

    ...we are getting about 10% of people whose original invite codes are not working, although entered properly in the backend

    Are these users entering it properly in the front end? Do you notice a certain pattern with the codes for this 10%?

    One thing I wonder though. Does a invite code that a member reports as not working work for you, if you were to try to register using that code?

    Please advise,
    Michael

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.