Why are there no widgets with this?

Hi

Trying out this system as used to using Pagelines DMS. Initially been quite disappointed to be honest.

Few issues:
1. Why is there next to nil documentation for this framework? A single PDF that covers the real core basics is really a shame.
2. Why do the widgets disappear when you active this theme? I was finding even the simplest things like trying to create a box area that was client friendly really, really difficult using the fixed widths provided and not percentages - not to mention not being able to target areas in your own draggable elements without first viewing the site elsewhere and then inspecting those elements, jotting down required classes, adding them to the css and then finally being able to style them. Not really the kind of simplicity this theme claims to have.
3. The display of the site varies intensely from the editor view to when the site is live, down to what's lined up, how it reacts etc. Classes are also lost that were assigned to buttons etc meaning the need to go back and reassign them.
4. The element choice is hugely limited on the left, are there any more elements or will they come in time?
5. Upon trying to create a 'box' like area, so image on top, centered text below, the image that has a center option refuses to center when selected.

I really really wanted to like this system and still do, but at the moment the DMS is miles ahead in terms of simplicity and being able to be confident that a client could use this to edit their site.

You use a theme to create a limited, set layout that you can just style up and the client can customise very little. This seems very well kitted out and suited to try and be a 'framework' - yet it feels restrictive and with such limited documentation even when you face a problem there is nowhere to consult for advice on creating simple concepts.

Many thanks

  • aristath

    Hello there @Paul Mabin, i hope you're well today!

    1. Why is there next to nil documentation for this framework? A single PDF that covers the real core basics is really a shame.

    That's because we're still not on version 1.0!!

    2. Why do the widgets disappear when you active this theme? I was finding even the simplest things like trying to create a box area that was client friendly really, really difficult using the fixed widths provided and not percentages - not to mention not being able to target areas in your own draggable elements without first viewing the site elsewhere and then inspecting those elements, jotting down required classes, adding them to the css and then finally being able to style them. Not really the kind of simplicity this theme claims to have.

    I guess that's a matter of opinion...
    You can add widgets and widget areas yourself in the theme editor. :slight_smile:

    3. The display of the site varies intensely from the editor view to when the site is live, down to what's lined up, how it reacts etc. Classes are also lost that were assigned to buttons etc meaning the need to go back and reassign them.

    That's not supposed to happen... Do you have any caching plugins installed on your site?
    If you do, could you please try deactivating them?

    4. The element choice is hugely limited on the left, are there any more elements or will they come in time?

    In time. We started with the basics and will be adding more as we go. :slight_smile:

    5. Upon trying to create a 'box' like area, so image on top, centered text below, the image that has a center option refuses to center when selected.

    Could you pelase post a link on your site where this occurs so that we may check this out in action? I was unable to replicate this on my test installation...

    Thank you for the rest of your feedback. :slight_smile:

    Cheers,
    Ari.

  • Paul Mabin

    Hi Ari

    Thanks for your response.

    It was the fact that I didn't realise all the widgets were done through the front end, didnt make sense to me! ha.

    This is the URL modbox.wpengine.com - I have unlocked support access. The widget I am using on the homepage isn't sliding as it should be, and the slider I have been trying to get full width just doesn't snap right, it's either too small or goes to about 8% width.

    Fair enough if it's still early days, but the way it's marketed doesn't make it seem that way at all!

    Apprecaite any help you could provide. The boxes are on there too you can see where I am trying to create them, yet they display oddly. We have been working from a visual in the hope I could create it quite quickly but having troubles.

    Would be awesome if you could take a look at the visual and give your take on how you'd achieve that the most efficiently with your system, and still keep it easy for clients to edit of course. I want to try and avoid custom code areas or I wouldn't be using this hopefully great system.

    No caching plugins but I am using WP Engine and they use evercache. I can build on a staging environment that isn't cached and see if that helps, but actually that was where I noticed the problem on the non-cached version.

    Many thanks

  • Tyler Postle

    Hey Paul,

    Hope you're doing well today!

    Apologies for such a delay here. Ari is no longer working with us so I'm going back and cleaning up some past threads.

    Can you update to the latest version of both Upfront and the child theme you are using(spirit, scribe, or Fixer). Then let us know if that resolves the issue - there has been a lot of fixes since your last post here :slight_smile:

    If it's still an issue then please do grant access, preferably to your sandbox install, then we can take a closer look.

    Look forward to hearing back!

    All the best,
    Tyler

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.