Why aren't my customers being charged shipping?

I am running market press flexmarket on a multisite. I've checked my settings and my api username for the USPS, and all are in good order. However, shipping isn't being added to the carts. I have had 2 of my subsite owners report this same thing to me. Help!
http://www.artistsalley.net
I have enabled your support.

  • Patrick
    • Support Monkey

    Hey there @Dawn

    I hope you're well today!

    I just added 3 products to a cart; 1 from each of those two subsites, and 1 from your main site. No shipping charge was added to the cart at all.

    I just tried to set up USPS on my own test site, but alas, their silly form to create my credentials ( https://secure.shippingapis.com/registration/ ) won't switch over to allow me to select a Canadian province instead of a US state... yup, I'm a Canuck :slight_smile:

    Perhaps an American staff member would have better luck on this one. How's about we call in @Michael Bissett to give it a shot and test USPS shipping with global cart enabled on his site?

    What say you Michael?

  • Dawn
    • The Incredible Code Injector

    @Michael Bissett
    Could you take a look at this, please? I gave you the link in the chat room tonight.

    My site owners are losing money on each transaction, so I'm anxious to get this fixed.

    Thank you, everyone!

  • Michael Bissett
    • Recruit

    Hey @Dawn, my apologies for the delay here!

    After discussing this with the developer, @Jonathan, I've got a few questions here:

    - Was USPS working on your site properly before, or did you just set this up? I'm not even seeing that the USPS shipping options are being presented, and this error's showing up in the browser console:

    Uncaught Error: Syntax error, unrecognized expression: ##

    - Have you tried switching the theme to a default theme? With the Twenty Fourteen theme active on my test Multsite (I used the main site to test), I'm able to get the USPS form to show up at the bottom of the shipping form.

    What about disabling the other plugins? (I didn't have any others activated on my test Multisite)

    - I noticed that not all of your products have a weight, what products were you testing with? If there's no product weight, things aren't going to work properly.

    Please advise,
    Michael

  • Dawn
    • The Incredible Code Injector

    @Michael Bissett Thanks so much for looking into this!
    I just set this up on the kitkatkate subsite, and added weights for the 2 flannel pants products. The other subsite I gave you has weights for all mailed items (one is a pdf download).
    I haven't tried using a different theme, because I'm scared that doing this will screw up my sites.
    I can try disabling the plugins one at a time. I am using:
    Admin Menu Editor
    Advanced Access Manager
    All in One Webmaster
    Blogger Importer
    Contact Form
    Infinite SEO
    Limit Login Attempts
    LiveJournal Importer
    MarketPress
    Movable Type and TypePad Importer
    MP Anywhere Cart
    MP Custom Shipping Form
    MP Product Search Widget
    Multisite Privacy
    New Blog Templates
    Remove WP Dashboard Widgets
    RSS Importer
    Sidebar Login
    Signup TOS
    Simple Custom CSS
    Tumblr Importer
    Ultimate Branding
    Ultimate Facebook
    WordPress Importer
    WPMU DEV Dashboard
    WP Smush Pro

    Any idea which one to start with? If I delete one that is causing something to be limited or hidden, will that item then be visible?

  • Dawn
    • The Incredible Code Injector

    @Jonathan
    Could you PLEASE help with this? I've tried everything, and it still doesn't work. I'm feeling like no one is listening and I'm getting so frustrated with this. There doesn't seem to be a good reason for it to not be working, yet it isn't working. PLEASE help! Is there a different shopping cart I could use?

  • Dawn
    • The Incredible Code Injector

    @Jonathan Here's what else I've tried:
    I added FedEx credentials to the site KitKatKate. When I add JUST an item from that site to the cart, I am offered shipping choices at the bottom of the address page. However, no matter what I chose there, no shipping charges are transferred to the next page- payment. When I add something from kitkatkate's site and any other site, no shipping options are presented during checkout.

  • Michael Bissett
    • Recruit

    Hey @Dawn,

    With @Jonathan's help, we've got the answer to the situation here. :slight_smile:

    At the moment, it seems like the USPS shipping options don't play nice when the global cart is enabled inside of MarketPress, which explains why those options weren't showing up on your site when I tried testing there.

    We'll be fixing this up in the 3.0 release of MarketPress, but in the meantime, you'll need to utilize one of the other non-calculated shipping options available inside of MarketPress.

    My apologies for the stress that this has caused here, but for what it's worth, I hope that the workaround will work for you in the meantime!

    Kind Regards,
    Michael

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.