Why aren't today's imported appointments not showing up?

So I've set up everything to do with Google Calendar and it is working super nicely. Love your work with this plugin. Two thumbs up.
I set up everything last night and all the corresponding time slots to already Google Calendar booked appointments got blocked.
I did a little dance when I got that part going.

Logged in this morning with my test account, and it shows that all of today as available. Tomorrow, the day after, and even next week is fine. Just the next 8 hours or so.

I couldn't find any obvious settings to change.

Thanks for your help :slight_smile:

  • Michelle Shull
    • DEV MAN’s Apprentice

    Hello, San!

    I'd love to help! I just peeked at your settings, and according to your general settings, it's just before 10a on Wednesday, Sept. 3, so all the appointments after 10a are shown as available. If that's not the time where you are, you may need to change the time on your server to reflect your current time zone.

    In the meantime, you can make today's date an exception, which would count as a day off.

    Hope this helps!

  • San
    • Flash Drive

    Heyyy Michelle!
    Hope you're well today.
    I double checked all my time zones and all that. Everything seems to match. And yes, that was the time here in Melbourne, Australia.
    The odd thing was that when I had a look early in the morning the last appointment for the day was there. But an hour or so later it disappeared too.
    As I mentioned, tomorrow and Friday and next week are as they should be.
    Everything else is working perfectly.
    Thanks Michelle ????

  • Tyler Postle
    • CGO

    Hey San,

    Hope you're doing well today!

    Just to make sure, you have double checked that the time zone in your WordPress install matches that of your Google Calendar?

    If so, then yes do you mind sending in your login information through our private contact form :slight_smile:

    Send in:

    Subject: "Attn: Tyler Postle"
    -WordPress admin username
    -WordPress admin password
    -login url
    -Google calendar access (doesn't have to be main account) any account that has full access to that specific calendar
    -link back to this thread for reference
    -any other relevant urls

    Select "I have a different question" for your topic - this and the subject line ensure that it gets assigned to me :slight_smile:

    https://premium.wpmudev.org/contact/

    Look forward to hearing back from you San!

    Have a great weekend.

    Cheers,
    Tyler

  • San
    • Flash Drive

    Hi Tyler. Hope you are well.
    I'm not sure how I can share my Google Calendar with you without sending the login details to my entire Google account.

    Google and Wordpress are both set to Melbourne, which is +10 hours.
    I did a little test, and appointments are dropping off at 9 hours before event.
    So a 5.30pm appointment dropped off at 8.30am (9 hours before).

    Thanks again for your assistance.

  • Tyler Postle
    • CGO

    Hey San,

    Hope you're doing well today and thanks for getting back to me!

    I can give you my gmail address then you can give me full permissions to that particular calendar :slight_smile:

    Before we do that, can you check your appointments+ logs? You can do this via:

    Appointments > Settings > Logs Tab. There should be some errors in there somewhere from the apps not importing successfully.

    Paste those in here if there are. You can remove any private information (ie. email etc.).

    Look forward to hearing back!

    All the best,
    Tyler

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.