why can I no longer post to Facebook Page only profile option?

Hi @anastasia,

you checked out my support post the other day and assured me it was working fine. Since then my site was down due to hosting issue with database.
Anyhow, my site is back up and some things I have to setup manually though database was restored but I can now only see the option to post to profile not page anymore.

Also, I am now using multisite so I am not if I should have the api and facebook key info setup both to network activated or individually. Help please as autoposting is an important feature on my site.

BTW: support access is activated in case you need to view site
Thanks.

Cheers!

  • Predrag Dubajic

    Hey @Jo,

    Hope you're doing well today :slight_smile:

    Not sure if this is related to your hosting issue but the app doesn't look like it's configured correctly.

    Can you try creating new App following the instructions from the below thread and try connecting your Ultimate Facebook with that App and see if it's working after that.
    https://premium.wpmudev.org/forums/topic/how-do-we-use-ultimate-facebook-plugin-with-the-new-app-ver-20?replies=5#post-884161

    Best regards,
    Predrag

  • Jo

    @Anastasia. Thanks for the speedy reply. Can you please update your tutorial as facebook has made many changes since back in 2012 when it was relevant.

    You also didnt answer if now since it is multisite if I should fill in the app api/key into both network and regular wordpress area(both places)?

    Can you please take another quick look at the site as I guess you read my mind and I did setup new app and added info. Did a sample post to see if it would show and it hasnt so far. I will check back for your reply in a few hours as I have been up all night trying to fix this. Again support access is granted. Please tell me what wrong with it now?

    Thanks,

    jo

  • Predrag Dubajic

    Hey Jo,

    You also didnt answer if now since it is multisite if I should fill in the app api/key into both network and regular wordpress area(both places)?

    Sorry I missed this part.
    This actually depends on how you want your network to work, when you go to Ultimate Facebook settings in Network admin you can choose some options regarding network settings, see first screenshot attached below.

    When I check your settings again the error is not showing like before, so I checked your main site settings where you actually have disabled auto posting to FB, see second screenshot attached.

    Since this was disabled I have created new post on your site and in post scrolled down to enable auto posting for that specific post, see third screenshot.
    And now, as you can see on your FB page and last screenshot attached you will see that the post is added to the page.

    Also, I have notified our project writers about the lack of information in documentation :slight_smile:

    Best regards,
    Predrag

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.