Why can't I install Anti-Splog on a BuddyPress site that isn't Multisite?

So I went to the WPMU Dev Plugins page in my WordPress backend to install Anti-Splog on my BuddyPress site (not Multisite), and it said "Requires Multisite", so I can't install it. However, on the WPMU Anti-Splog page (https://premium.wpmudev.org/project/anti-splog/#detail), it says it works with Multisite OR BuddyPress. Can anyone help me understand what is wrong?