Why do I have to mannually activate new members to my membership site?

I have the membership site plugin and I have to manually activate all users. They use the activation email they are sent but they still appear inactive and they can't get in until I manually make them active.

  • aecnu
    • WP Unicorn

    Greetings jp49911,

    Thank you for bringing this significant item to our attention.

    Sorry to see that you are having an issue with the Membership plugin.

    There can be a couple of reasons they are having this issue, so lets dig in.

    Is it a free or paid membership or a combination of the two?

    Regardless of free, paid, or the combination of the two, what Payment gateways do you have activated?

    What is the URL to your membership site?

    Please advise.

    Cheers, Joe

  • aecnu
    • WP Unicorn

    Greetings jp49911,

    Thank you for the additional clarification but I think there is indeed some confusion here.

    First regarding the site, is it paid or is it free? In the above post it is represented as both:

    It is paid and my site is http://www.sdprofessionalstraining.com

    ~and~

    The site is free so I don't have any payment gateways.

    Please clarify this but in any event you MUST have a gateway activated and even if the site is indeed free then minimum the "Free Subscriptions Gateway" must be activated for the Membership plugin to perform correctly.

    Please advise.

    Cheers, Joe

  • aecnu
    • WP Unicorn

    Greetings jp49911,

    Thank you for the additional input and indeed that should do the job for us.

    Now all future accounts (except those manually added) should be auto activated after the Member has gone through the registration process.

    Of course let me know if you have a contrary reaction by simply check marking this ticket as not resolved below and posting any error and/or symptoms that you are experiencing.

    Thank you for being a WPMU DEV Community Member!

    Cheers, Joe

  • aecnu
    • WP Unicorn

    Greetings jp49911,

    Can you please post a screen shot of those members that have signed up and are not activated? So I can see all the settings from left to right? From the Membership --> All Members screen?

    I tried to signup but need an invite code as well.

    Please advise.

    Cheers, Joe

  • aecnu
    • WP Unicorn

    Greetings jp49911,

    Thank you for those wonderful screen shots which indeed tell the tale.

    I removed the first screen shot because it was showing email addresses and removed it for your members email address security.

    Make note of what is displayed under Gateway it says admin - these indicate that they were added manually and not following the registration process ~or~ that no gateway was activated when they were indeed added.

    The gateway can be manually changed the ones that currently exist.

    Next we want to cover subscriptions. Can I please see a screen shot of the current subscriptions page? Similar to the one I have attached below?

    Please advise.

    Cheers, Joe

  • PC
    • WPMU DEV Initiate

    Hiya,

    Greetings and thanks for being a great community member.

    We haven't heard from you on this one for long and I am doing a regular followup to see if there is still something we can assist you on this thread.

    Just to manage the support issues more efficiently, I am marking this thread as resolved for now however this is not being done to avoid your questions in any ways.

    Please feel free to mark this is "Not resolved" in case you have further questions and we would be back on it.

    Thanks a lot for being with WPMU DEV.

    Cheers
    PC

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.