why does the register page have 4 fields for password?

http://wallplay.me/creators/register/

Create an Account
First Name
Last Name
Choose a Username
Email Address
Password
Confirm Password
Password:

(Leave fields blank for a random password to be generated.)
Confirm Password:

(Type your new password again.)
Register My Account

  • Predrag Dubajic
    • Support

    Hey @Laura O'Reilly,

    Hope you're doing well today :slight_smile:

    This is some strange behaviour for sure and looking at your settings I'm not sure what can be the cause of this.

    Could you please try running the basic troubleshooting here by disabling your other plugins and switching to default WP theme to see if the form is showing normally then.
    If yes, then try activating the plugins one by one to see which one is causing it.

    Looking forward to your response.

    Best regards,
    Predrag

  • Laura O'Reilly
    • Design Lord, Child of Thor

    I understand that by turning off all of the other plugins, and reverting to twenty fifteen would naturally likely get it working. But that is not the most efficient method. Why not just look at the code.

    Did you look at the code? or is this one of those knee jerk responses made by support staff taht do not take the time to actually look at the page and look at the code.

    Please advise and let me know if you actually looked at the page and looked at the code.

  • Laura O'Reilly
    • Design Lord, Child of Thor

    ms-extra-fields
    looks to me like ms as a part of membership 2??? has extra fields. Is there a way to turn this off? Or perhaps we want to add extra fields to allow users to define themeselves as specific types of users, of which there will be two. Creators and Brands.

    Please advise.

    <div class="ms-extra-fields">
    <label for="password">Password:</label>
    <input id="password_1" type="password" maxlength="20" autocomplete="off" value="" name="password_1">

    (Leave fields blank for a random password to be generated.)
    <label for="password">Confirm Password:</label>
    <input id="password_2" type="password" maxlength="20" autocomplete="off" value="" name="password_2">

    (Type your new password again.)
    </div>

  • Predrag Dubajic
    • Support

    Hi Laura,

    Sorry for the delay on this one.

    I did check your site first time and had a look at your settings and it looked good, since this was not reported by anyone else my best guess was that it was some kind of plugin conflict, and it turns out I was correct as it was caused by the Set Password plugin and after I have disabled it only default password fields are being shown.

    I'm going to flag this thread for our developers to see how can this be fixed in the future, and thank you for bringing this up to our attention :slight_smile:

    Best regards,
    Predrag

  • Predrag Dubajic
    • Support

    Hi Laura,

    Since update for this solution is still not available could you try if this solution works for you:
    Go to Membership 2 > Add-ons panel and enable "Profile fields"
    Now go to Membership 2 > Settings > "Profile fields" tab and set the password fields to "Hide" during registration.

    Best regards,
    Predrag

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.