Why is a Facebook Album only showing 6 photos?

For a certain album:

https://www.facebook.com/media/set/?set=a.839238652761333.1073741833.395609443790925&type=3

On the webpage http://afcsoyfoods.com/photos/

It is only showing 6 photos. Both in the widget and on the photo page. I can set the widget photo quantity or gallery shortcode on Photo page to any value and it will only show a maximum of 6.

If I replace the album ID with another one like https://www.facebook.com/media/set/?set=a.398015140217022.98145.395609443790925&type=3 it will show more than 6.

What am I doing wrong?

Thanks in advance.

  • Vinod Dalvi

    Hi @DBWebDev,

    Welcome to the WPMU Dev community and thanks for posting on the forum.

    Could you please share me the Ultimate Facebook album shortcode that you are using?

    When inserting album in the page image image count is displaying in the Add FB photo light box as displayed in the attached screenshot?

    Also please check whether the solution posted in the following reply helps you.

    https://premium.wpmudev.org/forums/topic/when-pulling-facebook-albums-using-shortcodes-only-the-first-25-images-are-loading#post-423328

    Would you mind if I logged in to your site and did some testing? This might help get to the bottom of this faster. If this is ok, just grant me temporary admin access to your site by clicking "Grant Access" button in the WPMU DEV Dashboard Settings from the following path and reply on this thread after granting it?

    Admin -> WPMU DEV -> Support -> Support Access Tab

    If you have not installed WPMU DEV Dashboard plugin yet, kindly do that here : https://premium.wpmudev.org/project/wpmu-dev-dashboard/ and then allow access as per the above process.

    Kind Regards,
    Vinod Dalvi

  • DBWebDev

    Vinod, thank you for getting back to me. Here are the answers to your questions:

    1) The shortcode I am using is:

    [wdfb_album id="839238652761333" columns="4" photo_width="175" photo_height="175" limit="999"]

    I've also tried with different limit values and even without the limit attribute.

    2) How do you get the Add FB photo light box? There are no extra buttons on the WYSIWYG editor for working with the Ultimate Facebook shortcodes. I only have been using the shortcodes.

    3) The solution you linked to probably applies to an older version of the plugin. There is no option to reset the cache. But there was an option to refresh user access token, so I went ahead and did that.

    4) I've installed the WPMU Dev Dashboard plugin. Support staff access is granted and active.

    Thanks again for helping.

  • Vinod Dalvi

    Hi @DBWebDev,

    Thank you for your reply.

    1) The shortcode I am using is:

    [wdfb_album id="839238652761333" columns="4" photo_width="175" photo_height="175" limit="999"]

    I have tested on my test site using the same shortcode and it's working fine displaying all images from the album as displayed in the attached screenshot.

    2) How do you get the Add FB photo light box? There are no extra buttons on the WYSIWYG editor for working with the Ultimate Facebook shortcodes. I only have been using the shortcodes.

    You will get the Add FB photo light box on clicking the "Add FB photo" button displayed near the "Add Media" button on post/page edit screen as shown in the attached screenshot.

    3) The solution you linked to probably applies to an older version of the plugin. There is no option to reset the cache. But there was an option to refresh user access token, so I went ahead and did that.

    I think the resetting cache option has been removed from the plugin. As the shortcode is working fine for me so there is no need to use that option.

    4) I've installed the WPMU Dev Dashboard plugin. Support staff access is granted and active.

    I think the support staff access has been revoked automatically.

    Could you please regrant me support staff access and extend it for more period or just send log in info through our secured contact form: https://premium.wpmudev.org/contact/ so that i don't have to request it again and again?
    - Choose "I have a different question"
    - Include my name in the subject "Vinod Dalvi"
    - Include the URL of this post in your message so that I may track this issue better
    - Include login information (Wordpress admin info username + password )

    Regards,
    Vinod Dalvi

  • Vinod Dalvi

    Hi @DBWebDev,

    Extremely sorry for the delay here.

    The support staff access is not active or might have automatically revoked it.

    Could you please send me your site access details as described in my following reply posted previously so that i don't have to request you to grant support staff access again & again and waiting for it?

    https://premium.wpmudev.org/forums/topic/why-is-a-facebook-album-only-showing-6-photos#post-739536

    Regards,
    Vinod Dalvi

  • Vinod Dalvi

    Hi @DBWebDev,

    Thank you for sending me the site details.

    I logged in to your site did dome testing but didn't find any issue there.

    I have tested on my test site using the same shortcode and it's working fine displaying all images from the album so i think it's not FB album issue but your site specific issue.

    Could you please try using the same FB album with Ultimate Facebook plugin on any other of your site?

    This can also be due to plugin/theme conflict.

    You can just try on your development site using default WordPress theme like Twenty Thirteen and deactivating all other plugins as displayed in the flowchart on the following page to know which theme/plugin is conflicting if any.

    https://premium.wpmudev.org/manuals/getting-support/

    Regards,
    Vinod Dalvi

  • DBWebDev

    Vinod, I can get other albums to display properly just not that one. Yet you can get that album to work on your Wordpress installs. Also that album I'm trying to make work does display properly it just stops at 6 count in the loop.

    So this leads me to believe the problem still lies within the plugin code. Are you sure all variables are sanitized properly? Have you double checked the loop part of the code to make sure there isn't anything there that shouldn't be?

    If there is a conflict between the plugin and themes then it is most likely because you aren't using unique variable names. That should definitely be corrected because WPMUdev users are definitely not sticking to the built-in WP themes like Twenty Twelve, Twenty Thirteen and Twenty Fourteen

  • Vinod Dalvi

    Hi @DBWebDev,

    Vinod, I can get other albums to display properly just not that one. Yet you can get that album to work on your Wordpress installs. Also that album I'm trying to make work does display properly it just stops at 6 count in the loop.

    Yes it is.

    So this leads me to believe the problem still lies within the plugin code. Are you sure all variables are sanitized properly? Have you double checked the loop part of the code to make sure there isn't anything there that shouldn't be?

    I have notified the plugin developer to get his reply here regarding this. He will reply here shortly.

    It would be helpful for us to get to the bottom of this faster if you test whether there is any plugin/theme conflict on your site or not.

    Thanks,
    Vinod Dalvi

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.