Why is domain mapping showing up twice in my network admin settings

In the Network admin settings, Domain Mapping shows up twice in the settings area. When I click on the lower one, it redirects to a page that says: "Please edit your /home3/XXXXXX/public_html/wp-config.php and move the line define( 'SUNRISE', 'on' ); above the last require_once() in that file or make sure you updated sunrise.php."

When I click on the other Domain Mapping link in settings, everything appears to be normal (except that I am having trouble logging into eNom). I have the sunrise.php file in wp-contents and the define( 'SUNRISE', 'on' ) line of code in wp-config just below the wp-debug line.

When I network disable the plugin, the normal Domain Mapping link goes away in settings, however the other link with the error message is still there. When I re-enable Domain Mapping the normal version reappears. I can edit settings and everything appears normal, although, as I mentioned, I am having trouble logging into eNom from the Domain Mapping login area in settings (I did submit a support ticket with them and they added my IP address to the live environment, and I set up a testing environment with them). Could the two issues possibly somehow be related? Thanks for your help

  • PC

    Hey there,

    Thanks for posting on the forums.

    It seems that it might be caused due to a conflict or improper configuration.

    So can you kindly make sure you setup the plugin according to the guide here : https://premium.wpmudev.org/project/domain-mapping/#usage ?

    If yes, can you kindly check for a plugin conflict using the screenshot on the page here : https://premium.wpmudev.org/manuals/getting-support/ ?

    Please advise if that helps us narrow things down.

    eNom issue can be due to the host IP being blocked on eNom servers. Sometimes you have a different IP and the requests are sent to eNom using a different IP so if the login still does not work, ask your host if the requests are going through a different IP than your dedicated IP and get that white listed as well.

    Please advise.

    Cheers, PC

  • Isaac

    Hi,

    Thanks for the quick response. When I originally set up the plugin, I used the domain mapping guide you linked. The plugin was working until today, and I have previously added multiple other domains using the plugin. I tried deactivating all of the plugins (network activated) and the problem still persists. Just to be clear, I have a bunch of plugins and themes activated on sub domains within my network that are not network activated. I deactivated just the plugins that were network activated, and set the theme on my main site to twenty fourteen. I have the Pro Site plugin set up with premium themes and plugins, many of which are in use on subdomains. It would be very difficult to deactivate all of the plugins and themes on the subdomains, Is this what you are suggesting?

    I forgot to mention, I also get the same error message I indicated in the original post when I click on the Domains link in Network Admin Settings.

  • PC

    Hey there Issac,

    Thanks for posting back.

    No worries if you can not disable plugins, I'd have a closer look to see if I can find something in the settings.

    I will need to have a closer look at your site with more details.

    Can you please send me your login details via our secure contact form

    1: Mark the email to my attention

    Attn: PC

    2: Include a link of this thread in the email

    3: Include FTP and WordPress super admin details.

    4: While filling the form, select "I have a different question" from the list.

    Looking forward for a response on this.

    Cheers, PC