Why is editor running all my text together in visual mode?

I have a Job Listings plugin.

It apparently is not the plugin.

Can someone please assist in working out why, when I enter all the text in lines, as soon as I save a draft it runs all the text together and EVERY TIME I access the page I have to (laboriously) redo it again, only to have to save it and the text goes back to being all run together.

It is doing my head in and I don't have time (or expertise) to work out what is going wrong.

The developer of the plug in says it is something to do with Editor, but why when it all used to work fine????

Thanks.

Karen

I have a screenshot to add but will have to post this before I can add it it seems.

I will open access for someone to check it out. Thanks.

  • Milan
    • WordPress Wizard

    Hello @Karen,

    I hope you are having a good day and thanks for your question. :slight_smile:

    First of let me explain a bit more about how you can ask us question with screenshot as it will help you in future when you want to ask us again. :slight_smile:

    First of all just go to our forum page here and hit link Ask a question. It will pop up one form for you, and than form will have option for attachments. Please do refer attached screenshot for understanding this simple process better. :slight_smile:

    Now let's talk about your question. :slight_smile: First of all thanks for granting us support staff access right on.

    You've said you have Job Listing Plugin which is third part one. Dear member I want to inform you that we do not cover support of third party plugin here as we are not fully aware about how it works and how it developed.

    However I've tried to add few job listing with plugin you mentioned but wasn't able to replicate issue. I was able to add same content as you've used in your job listing and saved job as draft. It displayed me without any issue after saving I've attached screenshot for your confirmation too. Can you take down quick plugin conflict for your issue ? You can use this flowchart as reference to know how to do
    https://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    Thanks & Kind Regards,
    Milan Savaliya.

  • Karen
    • WordPress Warrior

    Milan

    Thanks for the quick response.

    I did the question from within the WPMU Dev dashboard (where I normally post questions as I am usually on the page when I am experiencing issues. Part of the problem is that that is the quickest way for me to post. I don't have quick access to anywhere else as I have so much open it is hard to recall the location of everything so the Support link from within the WPMU site for my website is easiest - could they not just attach a paperclip to link things from there when you list a support question? It seems odd to log on some other way just to add something that explains the very issue you are listing. FYI.

    I am now puzzled as to why it works for you and not for me.

    I enter the data all laid out (either directly typed in OR copied from a word document) and it runs it all together as soon as I "Save draft". It didn't USED to happen (I am a simple soul - it used to work and now doesn't and I haven't fiddled with anything. Checked with developer - no luck, checked with you and it works for you. Very frustrating when all I am doing is entering data.

    I even highlight the text and remove formatting if I copy it in. Still gives me just a load of run on text.

    Not sure what else to try now.

  • Karen
    • WordPress Warrior

    I looked at the TXT version and there seemed to be a whole heap of rubbish so I removed it from top and bottom.

    It appears that the <p></p> are not against each line. I put them in the text version and save draft and it goes back to run-on text.

    Any ideas on how to make it behave and do what I want it to ie WYSIWYG and not this constant changing all the time?????

    Thanks.

  • Predrag Dubajic
    • Support

    Hi Karen,

    I was doing some testing on your site and it looks like something is in conflict with TinyMCE on your site, I'm not sure what but there are few things outdated on your site, including your WP version.

    I would suggest making a backup and getting everything to latest version to see if the issue is still there after that.

    Best regards,
    Predrag

  • Karen
    • WordPress Warrior

    Predrag

    Hostmonster automatically updates to the latest WP version so I am surprised it is not the latest one. What is the latest version out of curiousity.

    What is TinyMCE used for - so I can work out who to talk to about it. Thanks.

    I have autobackup - via a Snapshot plugin via WPMU Dev so that should be happening every day.

    Thanks for checking.

  • Predrag Dubajic
    • Support

    Hi Karen,

    WordPress updates itself automatically to minor versions, meaning that if you have 4.3.2 and 4.3.3 comes out it will update itself, and 4.3.3 is the version you are currently on.
    However because of more changes that come in higher versions, for example updating from 4.3.3 to 4.4, it will ask you to update it manually so you have time to make a backup in case any of you themes or plugins are not compatible with the latest version.

    As mentioned above, you currently have 4.3.3 and latest version available is 4.4.2

    TinyMCE is related to your content formatting, those options when you create a page/post that allow you to select text alignment, font size, etc.

    Best regards,
    Predrag

  • Predrag Dubajic
    • Support

    Hi Karen,

    It's possible that you dismissed update notification by accident, you can go to Dashboard > Updates panel where you will see button to update your WP installation, just make sure you have backup ready before doing so, it's good to stay on safe side :slight_smile:

    Best regards,
    Predrag

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.