Why is my Favicon not showing?

Hi – I guess this isn’t strictly WordPress related, but it is a frustrating problem nonetheless that other WordPress developers must experience from time to time.

I have 3 sites that I’m working on. In the Apache http settings each redirects to https. With 2 sites, I uploaded the favicon.ico to the root folder and each worked flawlessly. I uploaded the same favicon.ico file to koobimo.media and no matter what I do it still displays the Plesk Favicon.

I have:

Manually deleted and replaced the favicon files

Refreshed my cache and deleted history countless times

Rebooted the server

When I manually point my browser at the file (https://koobimo.media/favicon.ico) I still get the Plesk Favicon even though I can clearly see the correct one sitting in my ftp programme!

any idea?

  • Ken Kimbrell
    • The Crimson Coder

    Hello Paul- Generally this is a problem with caching and the image files having the same name. Have you tried a plugin to generate the favicon and see if it overwrites the default Plesk Favicon. One that our members use quite a bit is this plugin:

    https://wordpress.org/plugins/favicon-by-realfavicongenerator/

    If that still does not work, then please give me some additional login credentials VIA our private form and I will further assess the issue for you.

    https://premium.wpmudev.org/contact/#i-have-a-different-question

    Please visit our private Contact page and complete the form with the following information:

    Subject: “Attn: Ken Kimbrell”

    In the Message box, please provide the following:

    – link back to this thread for reference

    – any other relevant urls

    – Admin login:

    Admin username

    Admin password

    Login url

    – Hosting Control Panel Login

    Admin username

    Admin password

    Login url

    – FTP credentials

    host

    username

    password

    (and port if required)


    Thank you for being the best part of WPMU DEV, and I hope you have a wonderful day :slight_smile:

    Ken – WPMU DEV Support

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.