Why, on God's Green Earth do you make the name of the zip file and the name of the directory into which it unzips different?
I'm working on Composer support which involves grabbing the version number from the end of the zip file name, then adding the package.json to the zip file which requires putting it into the subdirectory, then adding it to the zip file.
This is made extremely difficult since I have to special-case every bloody plugin.
A> Enforce good naming conventions -- there is no reason that 13436_wpmu-dev-dashboard-3.5.3.zip should unzip into a directory named "wpmudev-updates." That's just bad practice.
2> Even better, and in addition, please add Composer support files to all of your plugins. It's how all the cool kids are doing WP sites these days.