Why when I use "protected content" pages still show on the menu?

I have a problem with "protected content plugin"

I created a site with 9-10 pages on the menu. The goal is to have a membership site with 3 access levels. Main/Silver/Gold... and I use the plugin to:

1. Protect all pages.
2. Have them show for the specific access level.
3. However if you go to the website
http://www.uspeivbulgaria.com/academiq you'll see that the menu pages still show. Why? It says the content is protected, but I don't want the menu pages to show at all, except for the specific access level.

Is the problem in the plugin? Or is it the theme? Or is it me? Please help.

  • Michelle Shull
    • DEV MAN’s Apprentice

    Hi there, Petar!

    You'll need to protect those menu items, as well as the pages they link to. It's super easy to do, but it's also easy to miss. :slight_smile:

    I attached a screenshot, but here's the gist:

    1. Go to Protected Content > Protected Content.
    2. Select Coments, More Tag, and Menus from the side menu.
    3. Select your main menu in the top drop down.
    4. Add any of the items in that menu you need to protect in the second drop down.
    5. Go to your assorted memberships and allow them to view tabs as needed.

    That's it!

    Have a great weekend!

  • Petar
    • New Recruit

    Michelle, thank you for the reply :slight_smile:

    However, I did protect some of the menus even before
    posting here that still showed, and now as I saw your reply
    protected all menus and sub menus (my Cardinal theme has mega
    menus)

    And if you see the website now: http://www.uspeivbulgaria.com/akademiq
    now even more pages in the menu show?

    This is really confusing.

    I think we should somehow fix with the theme, because of this
    megamenu (submenu) option I've been using. I go to appearance
    and then MENUS to arrange the menus and how they show, and maybe
    this somehow isn't recognized from the plugin.
    The theme is "Cardinal"

    Is there another way to fix ? :slight_frown:

  • aristath
    • Recruit

    Hello there @Petar, I hope you're well today!

    Could you please grant us access to your backend so that we may see exactly what is happening?
    To do so, from your dashboard go to WPMUDEV => Support => Support Access and click on the "Grant access" button.

    Please note that you must have the WPMU DEV Dashboard plugin installed on your site to complete the above process.

    Cheers,
    Ari.

  • Petar
    • New Recruit

    Hey Ari,

    Thank you so much for the proposal. I really appreciate it.

    I switched to wishlist member plugin and it works fine with the theme menu. So the problem
    is fixed for now.

    Thanks again, and if I have a problem, I won't hesitate to ask!
    You guys rock

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.