Wiki 1.05 update driving me nuts

I have the wiki 1.04 PRO version installed. It keeps wanting to have me upgrade to the 1.05 LITE version. Then I lose all of the controls for allowing editing found in the pro version.

Is there a mismatch in the versioning with the pro and lite products?