Wiki comments with Comments Evolved for WordPress

I've just added the Comments Evolved for WordPress plugin to my site and I'd like to get it working with the WPMU Wiki plugin.

Comments are off by default on all of my wikis.

HERE'S WHAT I DID:
Enabled comments on a single, low-traffic wiki.
Cleared the W3 Total Cache.
Browsed to the wiki.

HERE'S WHAT I EXPECTED:
The Comments Evolved for WordPress element to appear below the wiki content.

HERE'S WHAT HAPPENED:
No Comments Evolved for WordPress element appears below the wiki content.

HERE'S WHAT ELSE I TRIED:
Deactivate, delete, reinstall, and reactivate WPMU Wiki plugin - same results.
Adding a comment to the wiki from WP-Admin - the comment appears neither below the wiki content nor in the "Discussion" tab.

  • Alexander

    Hi @Michael Fraase,

    I've done some testing here and I'm getting the same result. Looks like out of the box, they're not going to play well together. There might be some things we can do to make this work such as making a custom Q&A template. It would take a bit of time to get put together though.

    What theme are you using? Then I can try fixing this and possibly just get you some template code that will work in your theme.

    Best regards

  • Alexander

    Hi @Michael Fraase,

    I'm sorry for the delay here. And sorry for mentioning Q&A before - I had just been working with that plugin, but I meant wiki. (the testing I mentioned earlier was with wiki) I've done some testing here with the theme you're using. I've been able to override the archive template, but can't get the single page template working by creating a single-incsub_wiki.php file.

    I'm going to get in touch with the developer here to see if he can clarify about overriding an individual wiki page, or even about getting comments evolved working.

    Best regards,