Wikipop Plugin!

Hello,
I love this plugin so much!
Perhaps many haven't digged this yet but is a powerful WIKI plugin to view wiki articles inline. It has a good/simple interface embedded in visual editor to include wiki pages inside. But the plugin has been abandoned since 2 years. It all works fine but gave me few problems while opening it in certain custom posts! It doesnt work for Buddypress and i want it to work in Scholarpress Courseware. The frame pops out but the wiki-content is not grabbed inside. The code is small. Can anyone help me with this?
http://wordpress.org/extend/plugins/wikipop/
This is the Plugin!

  • Timothy Bowers
    • Chief Pigeon

    Hey there.

    WordPress 3.5 is about to be released, if you have issues now then you might have more once this goes live.

    Just to check which version was it you tested with? Was it the latest stable or the latest RC?

    I've not used the plugin myself before,

    So it works in normal posts? But not custom post types?

    How are the custom post types created?

    I'm guessing with the age that wikipop isn't a custom post type?

    Take care.

  • vinay_sagar
    • Design Lord, Child of Thor

    I've been using this since 1 and half year since some WP 3 Version. I've tested with latest version. I'm not much a coder myself,i should've spilled that before. It works great all the time but in Buddypress ScholarPress Courseware it doesn't! Created a lectures including this! It has to fancy pop and display the wiki page in a frame! The pop up happens inside BPSC but the content is not loaded. That's the problem i get from it.

  • vinay_sagar
    • Design Lord, Child of Thor

    Sorry Timothy!
    I have't checked after upgrading to 3.4.2 which i just did as per your suggestion.
    It now works perfectly fine! But the problem is coming with Visual editor! The toolbar is not showing up except toggle screen tool!
    Thanks for the help though.

  • vinay_sagar
    • Design Lord, Child of Thor
    // TINYMCE
    
    function addbuttons() {
    if ( ! current_user_can('edit_posts') && ! current_user_can('edit_pages') )
    return;
    
    if ( get_user_option('rich_editing') == 'true') {
    add_filter("mce_external_plugins", "plugin_load");
    add_filter('mce_buttons', 'register_button');
    }
    }
    
    function plugin_load($plugin_array) {
    
    $plug = WP_PLUGIN_URL . '/wikipop/js/editor_plugin.js';
    
    $plugin_array['wikipop'] = $plug;
    return $plugin_array;
    }
    
    function register_button(&$buttons) {
    $b[] = "wikipopButton";
    $b[] = "separator";
    if ( is_array($buttons) && ! empty($buttons) ) {
    
    $b = array_merge( $buttons, $b );
    }
    
    return $b;
    }
    
    add_action('init', 'addbuttons');
    
    ?>

    That is all the code.
    Thanks!

  • vinay_sagar
    • Design Lord, Child of Thor

    Reporting again!
    It worked for a while and doesn't work again. It's working in some themes and not working in other themes within the scholarpress courseware area. You can see it's working in FRISCO theme as in the first pic and not working in Magazine theme in 2nd pic. Should be some Java problem.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.