>> Wildcard DNS Availability unavailable

I have multi domain In my website
- I add 11 domains
- each got *.mydomain.com. A 178.01.01.01

I put sunrise.php in wp-content and add "define('SUNRISE', 'on'); " in wp-config.php

all Wildcard DNS Availability are unavailable in red.

Have you got an Idea why it isn't working well ?

I type skydim3d.com and always got root site comme1marque.com, Why ?

Thank you

  • Sajid
    • DEV MAN’s Sidekick

    Hi @Laurent_C,

    Hope you are doing good today :slight_smile:

    The settings seems to be right for wildcard subdomain in cPanel. Do you multisite network with subdomain setup or with subdirectory ?

    If its sudomain and its still not working then please grant support staff access so I can take a closer look. To grant support staff access go to WPMUDEV > Support > Support Access > Grant Access or see this manual.

    Take care and have a nice day :slight_smile:

    Kind Regards,
    Sajid J

  • Sajid
    • DEV MAN’s Sidekick

    Hi @Laurent_C,

    Hope you are doing good today :slight_smile:

    For some strange reason, I keep getting token expires error while accessing your site via support staff access.

    If its okay for you then please send in FTP (In case I need to edit the files) and administrator login details. You can send in these details using our private contact form in following format.

    Subject: "Attn: Sajid Javed"
    -WordPress admin username
    -WordPress admin password
    -login url
    -FTP credentials (host/username/password)
    -link back to this thread for reference
    -any other relevant urls

    Select "I have a different question" for your topic - this and the subject line ensure that it gets assigned to me :slight_smile:

    https://premium.wpmudev.org/contact/

    Take care and have a nice day :slight_smile:

    Kind Regards,
    Sajid J

  • Sajid
    • DEV MAN’s Sidekick

    Hi @Laurent_C,

    Hope you are doing good today :slight_smile:

    Thanks for sending the credentials. I could login and see that all of your domains (except main) DNS availability is set to unavailable.

    It means either you have not set wildcard DNS or they are not fully configured. Did you bought your domain from same host and they are all configured properly ?

    Please contact your host and ask them to setup your domains and configure Wildcard DNS entry.

    Hope that helps! If you still need assistance, please don't hesitate to ask.

    Take care and best wishes for 2016 :slight_smile:

    Kind Regards,
    Sajid J

  • Laurent_C
    • Syntax Hero

    Hi Majid, thank you

    Yes I bought all via OVH
    All are on a plesk server and I configure it like this : (i replace the real name with site1, site2 etc ...)
    ServerAlias *.mastersite.com
    ServerAlias *.site1.com
    ServerAlias *.site2.com
    ServerAlias *.site3.com
    ServerAlias *.site4.com
    ServerAlias *.site5.com
    <Directory /var/www/vhosts/mastersite.com/>
    AllowOverride FileInfo Options
    php_admin_flag safe_mode off
    </Directory>

    Is it wrong ?
    Thank you

  • Sajid
    • DEV MAN’s Sidekick

    Hi @Laurent_C,

    Hope you are doing good today :slight_smile:

    I am sorry but I am not really good with server stuff. Did you asked your host to configure it for you ?

    Please ask your host and let me know what they says so I can inform the developer about this issue.

    Take care and have a nice day :slight_smile:

    Kind Regards,
    Sajid J

  • Sajid
    • DEV MAN’s Sidekick

    Hi @Laurent_C,

    Hope you are doing good today :slight_smile:

    I am glad to know you have figured it out and thanks for sharing the solution with community :slight_smile:

    Marking it as resolved for now, feel free to start a new thread or mark it not-resolved if you need further assistance.

    Cheers, Sajid

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.