Wildcard subdomain A record setup in my hosting not working

Sites are created in network admin, but inaccessible due to 500 error. I now have a wildcard subdomain A record setup but can't setup in my hosting admin panel. My hosting provider says "It is not possible to point the wildcard subdomain to the IP address of your own domain".

  • James Morris

    Hello danny,

    I hope you are well today. I'll be following up with you regarding your chat.

    Some hosting providers, usually shared hosting providers, do not allow you to setup wildcard DNS records. 1and1 is such a host. It's possible your host actively blocks this functionality.

    The way wildcard records work, you need to be able to setup a record that resembles something like the following:

    *.domain.tld IN A 192.0.2.1

    Where domain.tld is your domain name. This needs to be an A Record. If your host is saying you cannot point a wildcard to your IP, then they've disabled this functionality. It is a standard feature in DNS, but they must not allow it.

    If this is the case, then you will not be able to setup your Multisite Network to use subdomains that are created automatically. You will have to do one of the following:

    1. Manually create the subdomains and point them to the root directory of your Multisite install.
    2. Use the subdirectory model of Multisite and use a plugin like Domain Mapping to map the desired domain to the network.

    Depending on your hosting environment, both options should work.

    I hope this clarifies a bit. Let us know if you have any further questions. We'll be happy to help! :slight_smile:

    Best regards,

    James Morris

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.