Will Automessage work with Amazon SES?

There's a WordPress plugin that makes WordPress e-mails use Amazon SES instead of WordPress's PHP - will Automessage work with this?