Will PHP 7.0 plus, affect older website plugins negatively?

Hi.
My website has been slowly built over many years, on the same development server.

The server is running on an early PHP version (php 5), such that more recent WPMU plugin updates render some plugins unsuitable!

If I update, will other less modern plugins still function with PHP 7, (generally speaking), please??

Regards
John