Will wpmu dev's latest plugins and themes also with with 2.9.2?

I see language that says "compatible with" - does that mean "requires"?