Woo commerce login/logout on multisite

Hi,
I am having a major issue that the hosting company Kinsta (running Nginx and php7) seem not to be able to handle.

We have two sites - muddycreatures.com (main) and cubscartel.com (sub) and after the move to Kinsta WooCommerce customers can't login/logout from frontend. We have this plugin installed: https://wordpress.org/plugins/wordpress-mu-domain-mapping/

I will try to explain where the issue is:

On Kinsta server (Nginx) e.g. live site: https://www.cubscartel.com
- If already logged in from wp-admin I cannot login here: https://cubscartel.com/my-account/ as it never shows login screen as I am not logged out and can't log out.

- When trying to log out I am thrown to first one page (https://cubscartel.com/wp-login.php?action=logout&redirect_to=https%3A%2F%2Fcubscartel.com%2Fmy-account%2F&_wpnonce=11ace8980f) where I have to confirm the logout, and then to this default post page on main site: https://muddycreatures.com/?dm=fdab99c78a45afab3ed39ffc91de0889&action=logout&blogid=2&k=e93ca2e0febeecf6b67a1b313015177c&t=1672041252 which looks horrible.

On dev server (Apache) e.g. cubscartel.muddycreatures.greatsimple.com
- I can easily login.
- I can log out and when logged out I am directed to the my-account login screen.

  • Rupok

    Hi Maria,

    So sorry to hear the inconvenience you are having. This is weird and should not happen.

    I've not use Kinsta servers, so not sure what differences they have with other servers. And WordPress runs perfectly on my test with with nginx and PHP 7. So nginx or PHP version should not be the issue. But if they have customized configuration for nginx and PHP, then this might be the reason behind this.

    Can you please contact them regarding this? I believe they can give you best idea as they know how their servers are configured. Please let us know what they say about this.

    If they ask you to change something on your WordPress instance and if you are not sure how to do that, please let us know. We will be glad to help further.

    Or if you want, I can move your thread to our Members' Forum. There you can discuss this with our thousands of other members and I believe, among them, there will be lots of users who have experience with Kinsta servers. Please confirm if you want me to move this thread to there.

    Have a nice day. Cheers!
    Rupok

  • Maria

    Answer from Kinsta:

    Most of our customers run WordPress on our servers (NGINX and PHP7) without issue. There are no compatibility issues between a standard WordPress website and our servers.The issue we're up against is an incompatibility between something on this custom multisite network (plugin, theme code, etc) and our system. However, since this network is the only place where we've run up against this particular this issue, it's very difficult to say what might be the cause.

    I see that you've mentioned WPMU. Do you have a WPMU DEV membership? They have a domain mapping plugin that some of our customers use with success. I'm not guaranteeing this will solve the issue, but there are several warning in the error logs regarding the domain mapping plugin currently being used.

    Our recommendation is to set up an alternative domain mapping solution to see if this solves the issue.

    -----------------

    Is this something you can help with?

  • Rupok

    Hi Maria,

    So sorry if you were not happy with my previous reply. Actually I've not seen this type of issue before. And you said this setup is working on another server, so this is clearly your new server specific issue. And it's really tough to troubleshoot server specific issues without full access to your server and a wrong step can put the whole server down. That's why I suggested you to contact Kinsta first because they can give you best idea regarding their server configuration.

    Yes, our Domain Mapping plugin is compatible with nginx. You can surely give it a try.

    I can obviously have a look on your site if you want. In that case, would you mind allowing Support Access so we can have a closer look at this?

    To enable support access you can follow this guide here:
    http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Please confirm here when you are done granting Support Access. I'm looking forward to hearing from you and resolving this issue as soon as possible.

    Have a nice day. Cheers!
    Rupok

  • Rupok

    Hi Maria,

    I am sorry sorry for the delay in response and I do apologize for this. Actually, we try to reply older threads first and every time you put a reply on your thread, it becomes a fresh one and goes down in the queue. That's why the delay happened. However, from now on, we will try to prioritize this thread as it seems like you are in a rush.

    Thanks for granting Support Access. I logged in to check your issue and found some things. For example, you have changed your subsite URL to your mapped domain. This is absolutely okay and WordPress now supports it. But if you map your domains in this way, and again install any mapping plugin, that is an overkill. You can simply keep the original subsite address, and then map your domain through Domain Mapping plugin. This plugin gives you many advantages like Cross Domain Autologin, Forcing HTTP/HTTPS, set mapping redirection with just a click and lots more.

    However, I assume this is not the issue. So to investigate further, I tried to login in your cubscartel.com site, but that's asking me to login and I don't have credentials. So I could not check the actual issue you are having. Can you please send me a message with access credentials through our secure contact form here: https://premium.wpmudev.org/contact/ ?

    Subject: "Attn: Rupok"
    - WordPress admin Username
    - WordPress admin Password
    - Login URL
    - Link back to this thread for reference
    - Any other relevant URLs

    Select "I have a different question" for your topic. This and the subject line ensure that it gets assigned to me.

    After you send this, I'll be able to check the logout link not showing issue. And the two step logout issue generally happens for wrong nonce or if no nonce is passed. I can tell you better why this is behaving such if I can see the issue live and check your configuration.

    Please send us those credentials as soon as you can. I'll jump in after you send and will update you with my findings.

    I do apologize again for the delay. I hope you understand.

    Have a nice day. Cheers!
    Rupok

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.