Woocommerce not updating to paid status with the RedSys Gateway

After migrating from shared hosting to a VPS, Redsys payment (credit card) is not getting the "paid" variable.
RedSys is pretty similar to PayPal's gateway. It seems like if the status is not being updated to paid that there is a failure of communication on WooCommerce receiving the request of payment being made from the payment gateway. Complete third party request.

  • Predrag Dubajic

    Hey Jordi,

    Hope you're doing well :slight_smile:

    I did some investigations about this but I'm afraid that I can't similar reports to this issue, however since the issue started after moving your site to VPS it's most likely server related.

    There are few things that you can check as Woocommerce and some add-ons require specific settings.
    You should first check that your server supports Woo requirements:
    - PHP 5.6 or greater
    - MySQL 5.6 or greater
    - WordPress 4.4+
    - WP Memory limit of 64 MB or greater (128 MB or higher is preferred)

    And couple more things that are worth checking:
    - Some extensions require SOAP support as well as CURL or fsockopen
    - Multibyte String support
    - Check that ioncube is installed and that mbstrings are properly configured

    If none of the above helps I'm afraid that we can't do much here as we're not familiar with their code and full requirements so it would be best getting in touch with RedSys or Woocommerce support for more help.

    Best regards,
    Predrag

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.