WooCommerce store page not displaying with Fixer theme

I'm trying to set up woocommerce with Upfront but no products are visible from the store page when Fixer theme is active. While all the products are displayed using default Twenty Sixteen theme.

  • Majid

    Hello Wayne,

    I hope you are having a nice day!
    I tried opening the builder but It was stuck, I would like to check this issue too. because it might something related to memory.

    Please send me extra info using this form here
    https://premium.wpmudev.org/contact/#i-have-a-different-question

    Subject: “Attn: *Majid Hamdani*”
    - WordPress admin username
    - WordPress admin password
    - Login URL
    - FTP credentials (host/username/password)
    - Link back to this thread for reference
    - Any other relevant URLs

    Talk soon,
    Majid

  • Patrick

    Hi there Wayne West

    This is to follow-up on our live chat from yesterday.

    Your site could certainly benefit from an increase to max_execution_time, which is currently set to 30 seconds. That could be increased to 300 in your php.ini file, or at least 180 if your host does not allow more.

    Also, while trying to login to your site again after I got mysteriously bumped out, I was greeted by a "508 error: resource limit reached, try again later" message, which would tend to indicate that your host is imposing unrealistic limits on bandwidth or other server resources. You may with to talk with them about increasing that, or moving to a better plan.

    However, none of that has anything to do with why WooCommerce products were not showing on your /shop page.

    The thing here is that you had a gallery element on that page that had somehow replaced the Woo content. I have deleted the original /shop page you had, and have created a new one. I have also updated your install of Upfront to latest version.

    I have added an Upfront Posts element to the page, and have it configured to display Woo products. Your Woo products are now displaying on your /shop page.

    I've also added a couple of lines of CSS to the Global CSS section in the Theme Settings (in the Upfront editor sidebar) so your products now display on that page in a nice grid instead of a list.

    Please also note that is important to not change the template used for that page in the regular WordPress editor in your wp-admin, as that will cause any content or changes you have made using the drag and drop Upfront editor to be lost.

  • Ken Kimbrell

    Hello Wayne West -

    I did notice one image dragging on the parallax of the main page. I managed to solve that by switching to the Transparent_Logo image. For some reason the other image was causing the background image to drag. I also noticed that your homepage is at 5MB. The standard you would aim for would be around 2.5M to ensure that the page is not bogged down and creates slow load times. This can sometimes be an unrealistic goal depending on the graphics needed for the site, or if doing a portfolio site where high resolution images are required.

    You could also utilize a lazy image loader to help with speeding up the site and keep it from being bogged down. I honestly feel that some of the dragging issues may be correlated with a heavy front-end page. Here is a great thread on lazy image loading:
    https://premium.wpmudev.org/forums/topic/woocommerce-store-page-not-displaying-with-fixer-theme

    Some things to consider in countering that, is to make sure you have caching turned on, of course I know you are in development phase and that is not needed as of right now. However it will help returning users in the future.

    Also consider using a CDN to deliver content. This will help speed up the front-end, especially a site with heavy content.

    A good one I recommend is cloudflare:
    https://www.cloudflare.com/

    Make sure you defer the parsing of any plugin javascripts that will not be needed on the homepage, and deactivate any plugins not currently in use.

    You can also defer parsing by putting plugin's .js files in the footer. I see you have hummingbird enabled and we made that conveniently possible for you by going to Hummingbird > Minification and activating minification. From there you can choose to put minified files on our CDN if you wish. You can combine and even move files to the footer. Be careful when moving scripts to the footer, as it can break your site layout. Maybe make a few changes save and observe that functionality of the site has not been broken.

    A performance scan I like to use is https://gtmetrix.com, I like their detailed descriptions to the problems and shows you the best performance results. You can use this data to further optimize your site. Now I know your question was not directly related to optimization and you may know some or all of what I said, however at least it will give you the reassurance if you are taking these steps that you are right on track.

    As for the responsive end, I did not see any specific things that stood out. Could you be more specific on what you are seeing that is causing the site to be messed up from a responsive standpoint that way we can look into how to resolve the problem for you?

    Let me know how I can help!

    Take Care,

    Ken - WPMU DEV Support

  • Wayne West

    Hmm I have personally resized every image and then uploaded and used the image smush mimification as well and we do have a cdn just tunred it off while you guys were trying to find out what the problem is. . I wonder if maybe it isnt picking up the new images? please see attached to see what we are seeing on cell phones. The server company has made the changes to 300 instead of 30 as well like patric has asked. Also I notice when I go to https://hausofk2.com/shop it says fixer?
    But as for the image here is exactly what we did. We had them all uploaded but then I deleted them from media and then resized to 30% of there origional size then uploaded them again. Then did smush and mimificaiton. As for why its showing 5 idk

  • Ken Kimbrell

    Hello Wayne West -

    Yes it does appear I did not scale my window down to 320px due to having too many tabs open and this one slipped by me :o. I do apologize for that. I have seemed to discover a strange margin error only being added with a viewport width of 320px. So in your child-theme's style.css I added this line of custom css:

    /***Adjust the margin on Mobile Viewport width of 480px***/
    @media only screen and (max-width: 480px) {
        img.upfront-image-lazy.upfront-image-lazy-loaded {
            margin-left: 0px !important;
        }
    }

    This seemed to solve the marginal error.

    I hope this helps!

    Take Care,

    Ken - WPMU DEV Support

  • Rupok

    Hi Wayne West,

    I'm extremely sorry for the delay from our end.

    Your shop page had a wrong menu selected for the header and as that layout was reset, it was showing Fixer logo. I've deleted the fixer logo and contact element from the header and set the proper menu and also changed the menu color to dark as the background is white. Can you please check and confirm?

    Regarding homepage, the area under the header had a parallax settings, but probably a small image was set as that region background. That's why it was showing an odd image. However, I've changed that image and set a resized version of the logo there. Now it's not showing weirdly. Please check the attached screenshot for reference.

    Can you please check and confirm?

    Please let us know if I missed anything. We will be glad to help further on this.

    Have a nice day. Cheers!
    Rupok