WooCommerce support for Upfront 1.0 themes

Am I right in thinking that your themes are not compatible with WooCommerce?

I found a ticket from 2014 about this, but I'm very surprised that the latest version of Upfront doesn't address this.

For us non-coders it's a real bummer.

Are there plans to rectify this?