wordpress 404 issue

Out website is http://hpathy.com - wordpress multisite + buddypress

We have recently installed arrowchat (arrowchat.com) but the chat is not working. The support company says that something is giving a 404 response to all get responses. This is probably happening only to ajax calls but not very sure as the rest of the site seems to be working fine.

I have searched online, there are posts where people say that it could be some apache config issue, at other places people say that calling a wordpress function outside wordpress can give such error. BUt there is no definite cause and solution for such behaviour.

We were using v 1.07 of this chat app on our site till some time back and it was working fine. In last month we moved our servers and the chat was also upgraded to 1.5 v. So either the server or the chat has to have an issue. The chat company says its the server but nobody seems to know what's wrong.

Can any pro here have a look and give some suggestions to resolve the issue?

Thank you.
Manish

  • Moonworks
    • Code Wrangler

    Have you spoken to your host about the problem? They may have a solution, particularly if you tell them that this is an important part of your site and if it doesn't work you'll have to move to another host.

    I don't know if this will help you move forward with the problem, but I did find a page that mentioned that all GET responses have to be qualified by the cache-control and Expires headers. This wasn't specific to your problem, but it may help you towards a solution.

    Alternatively, have you tried the chat plugin on this site?
    https://premium.wpmudev.org/project/wordpress-chat-plugin

  • Hpathy
    • Site Builder, Child of Zeus

    I have forwarded the issue to my hosting company too. We are on a dedicated server. They are looking into it but those guys are not into programming kind of thing. So I thought I'll check with the experts here to see if there could be some other cause.

    Regarding the chat app here that you mentioned. It looks more like a support chat app and not a full-fledged chat for buddypress. I could not see any option to load friend list in it and mine did not load either when I tested it again just now. So if it doesnt have that option, then calling it buddypress compatible is not right.

  • 3SixtyEvolve
    • New Recruit

    Hi Manish

    Greetings from the WPMU DEV Support Team and thank you for being a member.

    Have you tried rolling back to the previous version of ArrowChat to see if it will work on the new dedicated IP hosting? If it does work, then you would know for sure that it's a compatibility issue between the latest version of ArrowChat and something on your hosting.

    At least you would go through the process of elimination. We can then do further investigation.

    Let me know how you got on with it. And also, thank you for your feedback on our own Chat Plugin. You should actually raise a separate post for this on our Feature Suggestions and Feedback Forum to see if it's something that the Developer could incorporate into the next version. Worth a try :slight_smile:

    All the best and talk soon!

    Gina

  • Hpathy
    • Site Builder, Child of Zeus

    Would like to share the reason for that bug. A folder with some js files was not getting the read permissions on install. This was causing a 404 when those arrowchat js was called. We fixed that and the new version of the chat app, which is MUCH better has also worked!

    Thanks for your help.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.