WordPress 4.7.1 Update and Compatability issues with E-Newsletter 2.7.3.8

I am being prompted to download the latest WordPress 4.7.1 - and to download the latest E-Newsletter plugin but the description says below that Compatability with WordPress 4.7.1 is unknown.