WordPress acting slowly.

My WordPress multisite has become very slow. After looking at stats etc, I installed new relic and it showed that my wp_options are responding very slow. I also see wp_domain_mapping is slow.

https://cdn.livechat-static.com/api/file/v2/lc/att-old/8801096/333eb7c8973269217c7ca050dd304b62/Screen%20Shot%202018-09-24%20at%201.33.02%20AM.png
https://cdn.livechat-static.com/api/file/v2/lc/att-old/8801096/79b28286b06d338cc2b4979c16c519c8/Screen%20Shot%202018-09-24%20at%202.13.28%20AM.png

And although I have over 700 sites under the same multisite, few sites it is showing gzip and cache is not working but others it is OK. Please help.

  • Adam Czajczyk
    • Support Gorilla

    Hello ella

    I hope you're well today and thank you for your question!

    I tried to check the site but I couldn't access it as Wordfence didn't allow me to get in, reporting that "access for my area has been disabled". I'm currently in Poland so if you got any "geo-locating" locks active, please disable them. In fact, whenever you come for a support, it would be best if you could make sure that one way or another the site can be accessed from anywhere in the world as we're a globally distributed company working from various parts of the world :wink:

    As for the issue. 700 sites on one Multisite install it's quite lot and while WordPress itself should be able to handle that, there might be some additional optimization/customization necessary. It's also possible that the server is not able to handle such a big setup and it might be necessary to consider switching to some other provider.

    Finally, the _options table, especially on such a big setup, can grow to a very big size which would also cause a significant slow downs, indeed.

    However, that's more of a "theory" rather than a specific diagnosis as I'm currently not able to access the site. That said, would you please make sure that no "geo-location" locks would be preventing me from accessing the site? For the start, I'd like to look into the backend to check its configuration to get a better idea of the entire setup

    Kind regards,
    Adam

  • ella
    • Flash Drive

    Hello Adam,

    Can you tell me what your IP is I can whitelist it. Also last night I disabled Utimate-branding as it was showing in newrelic as taking lots of seconds. As soon as I disabled sites speedup again. I think there is something with that plugin. I also see domain-mapping slow.

  • Predrag Dubajic
    • Support

    Hi ella,

    Our QA team is currently testing a fix for queries done by Domain Mapping which could cause your site to slow down, and if everything goes well during the test we should see new version live soon.

    As for the Ultimate Branding, we recently had a report for Favicons module causing the issue and is something our devs are looking at as we speak.
    Can you tell me if you also noticed UB affecting your site only with Favicons module active?

    Best regards,
    Predrag

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.