Wordpress and PHP5?

Throwing this out completely at random. A new version of Gallery was released within the last 24 hours and they're saying that it's coded for php5. (Although they don;t say it's specifically designed for php5.) We've having a rather heated discussion over my neck of the woods about asking Open Source developers to move completely over to php5 and away from php4. Considering that php is now on 5.3.2, I would think this would be a given. But then I look at DirectAdmin and they're still installing php 4.4 and 5.2. I don;t remember what CPanel installs.

Yes? No? maybe so?

edit: It's my understanding that php4.x has reached end of life but I can;t find that specific statement on the php website outside of a statement for the specific 4.0 version.