WordPress is creating multiple copies of images

I am setting up a WordPress multisite and noticed that there are numerous copies of my images in the folder after uploading one. The new images are renamed (a number prepended to the filename) and then Smushed to create multiple file sizes.

I literally have HUNDREDS of copies of the same image in different sizes, with different names. Any idea on what is causing this to happen? I have tried deleting the images, I have even deleted them from the server, but more keep showing up. The strange thing is, it's only happening with one file - the one I am using on the homepage.

I am using Upfront builder to create a custom theme to be used across all sites on the network.

  • James Morris
    • WordPress Enthusiast

    Hello Jessica,

    I hope you are well today.

    Hmmm... This is an usual issue. If this was happening for all images, it would make a bit more sense.

    In order to help you better with your issue, would you please grant me access to your site and server?

    Please visit the Contact page and complete the form with the following information:

    Subject: "Attn: James Morris"

    In the Message box, please provide the following:

    - link back to this thread for reference
    - any other relevant urls

    - Admin login:
    Admin username
    Admin password
    Login url

    - Hosting Control Panel Login
    Admin username
    Admin password
    Login url

    ~OR~

    - FTP credentials
    host
    username
    password
    (and port if required)

    Best regards,

    James Morris

  • Benjamin
    • New Recruit

    Hello. I'm curious about this. I run WP-Smush and have seen newly uploaded images being duplicated hundreds of times. Yesterday I uploaded an image which has now been duplicated 1033 times.
    This is exhausting space on my hosting and slowing the site down dramatically. Something appears to be driving these duplicates and it's chewing up my site!
    Did anyone look in to this?
    Thanks
    Ben

    • James Morris
      • WordPress Enthusiast

      Hello Benjamin,

      In order to ensure that we are addressing the unique needs of your particular situation, would you be so kind as to contact one of our Support Specialists via Live Support?

      This will allow us to do some preliminary diagnostics on your site. If we cannot resolve the issue in chat, our staff will create a ticket just for you so that we're giving you individualized attention and not getting your site's issues mixed up with another member's. Also, this reduces the amount of notifications being sent to the original member's ticket.

      Thanks!

      Best regards,

      James Morris

  • Jessica
    • WPMU DEV Initiate

    After a week, my site is creating copies of images again. Not sure if it has to do with installing WP Smush yesterday but that's the only thing that's been added in the last 24 hours. The site and Upfront Editor are lagging a lot today too, some images not even loading on the front end.

  • Jessica
    • WPMU DEV Initiate

    Has anyone had a chance to look into this yet? There are hundreds of duplicated images on my server, with more being created daily. I need to move the site over to the client's server soon and need to have this issue resolved before we launch the site.

  • James Morris
    • WordPress Enthusiast

    Hello Jessica,

    I apologize for the delay in reply. I've been looking into this issue for you.

    What I'm finding is images uploaded through the Media Uploader, but not associated to a post or page do not get unnecessarily duplicated. The thumbnail sizes are generated, but that's it.

    See:
    http://storage7.static.itmages.com/i/17/0922/h_1506054877_4940236_4f2cc1180a.jpeg
    http://storage9.static.itmages.com/i/17/0922/h_1506054894_3051899_47a12cf714.jpeg

    But, as you stated in your original post, the image used on the homepage is being duplicated numerous times. I've not been able to find anything in your configuration with our products that would cause such an issue, but I did find a plugin that *might* be causing this issue.

    I see you are running Multisite Post Duplicator. This plugin duplicates posts and pages, including images. Upfront uses custom post types to store data. It's possible that this is conflicting and Multisite Post Duplicator is duplicating data from Upfront.

    In order to test this, would you please disable Multisite Post Duplicator, remove the unwanted images, and see if the issue persists?

    Best regards,

    James Morris

  • Jessica
    • WPMU DEV Initiate

    Thanks James,
    The Multisite Post Duplicator *should* only duplicate content when it's told to, not automatically, but of course there could be a conflict there. I've disabled it and will wait a day or two to see if any images are still being copied.

    Jessica

  • Jessica
    • WPMU DEV Initiate

    Hi James,
    So I haven't touched the website in a couple of days and logged in today to make some revisions. The 2 images that are being duplicated are still doing so. It seems like anytime I go into the Upfront Editor (or Builder) it duplicates those images again).

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.