Wordpress Multisite File Upload Limit

I'm trying to change the File Upload Limit on my Wordpress multisite, which was 2MB. I followed instructions in a blog post - http://www.wpbeginner.com/wp-tutorials/how-to-increase-the-maximum-file-upload-size-in-wordpress/ and the limit shrank to 548kb instead.

Having changed it, you'd think I'd be able to figure out what made the change and how to increase it. But instead, I'm stuck at 548kb. I've tried to restore all the original settings and got nowhere. Am now really stuck! I need to correct this quickly. Help!

Jackie

  • Sajid
    • DEV MAN’s Sidekick

    Hi Jackie,

    Hope you are doing good today and thanks for your question :slight_smile:

    You can change the max upload file size from Network Admin > Settings > Network Settings > Upload Settings > Max upload file size (See screenshots)

    Try this method once and let me know the results. Before doing this revert all the changes you made.

    Take care and have a nice weekend :slight_smile:

    Cheers, Sajid

  • Jackie
    • Flash Drive

    Hi Sajid

    No joy. I think the problem may be the main blog's site upload space quota. It's 50MB - the network default. When I try and change it to 1000MB in the site settings, nothing happens - my setting is removed when I save.

    I've changed the site upload space quota on other blogs with no difficulty. How do I change it on the main blog?
    Thanks
    Jackie

  • Jackie
    • Flash Drive

    Hi Sajid

    I'm seeing database errors on my server. All the websites are down.

    Have you done anything that would cause that? I have a server support team. If it's nothing to do with you, I'll ask them to investigate.

    Thanks
    Jackie

  • Sajid
    • DEV MAN’s Sidekick

    Hi @Jackie

    Welcome back and thanks for granting support access but I have not logged in yet and did nothing on your website. It might be some thing else happening on your website.

    Let me know when the site is back and I will take a look at original issue.

    Cheers, Sajid

  • c0d3r
    • Design Lord, Child of Thor

    it is common problem when php gets crazy
    try to check php.ini for max upload
    then copy it to your wordpress folder
    try:
    1- the original php.ini named it php.ini.backup
    then wait until the server either clear the cache or the php.ini will take the file on your WP and apply it
    I had 1 MB
    now

    • Jackie
      • Flash Drive

      Thanks but that doesn't seem to help. I've successfully changed the max upload filesize on all blogs.

      My problem is now the main blog's site upload space quota. I can't seem to change that from the network's default 50MB. I can change other blogs' site upload space quota - just not the main one's.

  • Jackie
    • Flash Drive

    I think my php.ini settings were the problem. Mysql's never crashed before and that was the only thing I changed.

    I'd raised max_upload_filesize to 64MB and max_execution_time from 30 to 300. I've dropped them down again.

    Thanks
    Jackie

  • Sajid
    • DEV MAN’s Sidekick

    Hi @Jackie

    Its because of your site upload space. I increased the site upload space from 50MB to 5000MB and it seems to be working (see screenshot). It was 4MB before increasing the upload space.

    Hope this helps :slight_smile:

    Cheers, Sajid

  • Jackie
    • Flash Drive

    Hi Sajid

    I don't think this has actually fixed the problem. Strangely, I'm seeing something different. I've cleared my browser cache but:
    - the site upload space quota in my main blog's settings refuses to retain a value.
    - I'm still seeing a maximum upload file size of 4MB
    - and the storage space is shown as 50MB.
    (See attached images).
    I'm suspecting a plugin conflict, but am not in a hurry to disable them all. I'll need to clone and test my multisite on a test installation.
    Thanks
    Jackie

  • c0d3r
    • Design Lord, Child of Thor

    Hi
    The root of this problem come from
    1- php.ini (most common)
    2- Theme
    3- Plugin
    for starter, let's check your phpinfo
    create .phpinfo file
    type <?php phpinfo(); ?> and save it as .php
    then check upload_max_filesize
    if it is different than what you have in wordpress then try this
    create php.ini file and save it in /wp-admin/
    php.ini code:
    memory_limit = 200M
    upload_max_filesize = 64M
    post_max_size = 100M
    file_uploads = On
    -----------------
    some time it takes 20-30 minutes to get the results if this code doesn't work try this one
    upload_max_filesize = 64M
    post_max_size = 64M
    max_execution_time = 300

    same applies try to restart all the services and give it 20-30 minutes

    in case this doesn't work, add these lines to theme function
    @ini_set( 'upload_max_size' , '100M' );
    @ini_set( 'post_max_size', '100M');
    @ini_set( 'max_execution_time', '300' );

    you can even use .htaccess file, since it always communicate with the user
    create .htaccess file in /wp-admin/
    it will be same php.ini code above but with adding php_value before every line
    php_value upload_max_filesize = 64M
    and you copy and modify it

    let me know the results
    Good luck

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.