Wordpress MultiSite - wp-login Error 404

Dear WPMU Dev Team,

Would you please try to access my subdomain via wp-admin or through my Network Admin as it always returns a 404 Error? Support access has been granted to WPMU.

I have already successfully set up several MultiSites, but on this account I am facing the problem outlined above.

I have also gone through all your recommendations prior to writing this email. This MultiSite set up uses the latest version of Wordpress, Plugin & Theme tests did not make any difference and the Network Set Up parameters (.htaccess and wp-config) have been configured according to the guidelines.

I thank you in advance for your kind support in this matter and send
warm regards
Cherie

  • Rupok

    Hi Cherie

    I hope you had a wonderful day.

    As you confirmed that ".htaccess and wp-config have been configured according to the guidelines", there is another important thing which may cause 404 error for "subdomain" multisites - Adding wildcard DNS entry.

    Did you create a wildcard entry in your DNS settings for forwarding all your subdomains to your main domain for handling subdomains? You can get more idea about creating this DNS entry from here: https://codex.wordpress.org/Configuring_Wildcard_Subdomains

    I believe, it will solve the issue. If not, please let us know. We will be glad to help.

    Have a nice day. Cheers!
    Rupok

  • Cherie

    Hi Rupok,

    thank you for your quick reply... hope you had a good day too!

    Sorry, but I have to come back to your kind offer to help. In my previous email I forgot to mention that DNS settings have also been processed as required upon setting up my MultiSite, however the subdomain wp-admin returns a 404 error :
    1. Add A (Host) Record
    2. Add * (wildcard)
    3. Point to (IP Address)

    Steps 1 - 3 worked and still work in my previous MultiSite set ups.
    Is it now required to add the domain name to the * (*.domain.com)?

    Warm regards
    Cherie

  • Rupok

    Hi Cherie

    You said "Steps 1 - 3 worked and still work in my previous MultiSite set ups". Are those previous MultiSite setups are subdomain setup? If 1 - 3 worked for them, it should work for your new setup too. Would you mind allowing support access so we can have a closer look at this?
    To enable support access you can follow this guide here:
    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Moreover, can you please send me message with FTP credentials through our secure contact form here: https://premium.wpmudev.org/contact/

    Subject: "Attn: Rupok"
    - FTP Username
    - FTP Password
    - FTP Host
    - Link back to this thread for reference
    - Any other relevant URLs

    Select "I have a different question" for your topic - this and the subject line ensure that it gets assigned to me.

    Please don't forget to take a full backup of your site before sharing these access with us. It helps us to do risk free testing and find the solution faster.

    Have a nice day. Cheers!
    Rupok

  • Cherie

    Dear Rupok,

    thank you so much for your kind offer to help! Meanwhile the problem was solved as follows:

    Remark: Please note that this WordPress Multisite installation is managed via cPanel - my previous ones were not managed via cPanel.

    STEP 1. As mentioned above I added a WILDCARD * via
    > Domain
    > DNS
    > Add A Record (* WILDCARD)

    STEP 2. Added additional Wildcard via
    > cPanel
    > Add Subdomain * WILDCARD (*/domain.com)

    REMARK:
    - STEP 2 was not required in my previous (non cPanel) MultiSite installations
    - STEP 2 solved the 404 error for my cPanel MultiSite installation

    Once more I THANK YOU SO MUCH for your kind support in this matter and wish you a nice weekend!!!
    Cherie

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.