Wordpress No Longer Allowing Me To Publish/Edit Posts or Pages

I have a multisite network running the Avada theme on a SiteGround Cloud Server. I can get to the "Edit" page for any post or page in the network as the Super Admin, but I can't actually publish or update any pages. When I hit the button to do so, it kicks me out to the "All Posts" page within that site.

I just updated my Avada theme from 4.0.3 to 5.0.6, which included having to run a shortcode migration tool on each site individually. I have support tickets open on this issue with Avada and SiteGround as well.

I installed a new site into the network and activate the 2016 theme and it is also unable to publish changes.

I also tried to disable all the plugins (with the exceptions of two required Avada plugins - Fusion Core and Fusion Builder - and also with the exception of the domain mapping plugin, since that would break all my site urls.). Disabling the remaining plugins via FTP did not help.

I have gone in and enabled support access as well.

  • Rupok

    Hi Mark,

    This is really weird and should not happen. Thanks for granting Support Access. I logged in, created a new test subsite and tried to post a new post but I got the same issue you mentioned. I've never faced this type of issue before.

    Your server configuration may have some role in this, I'm not sure though. For example, your server config is allowing only 512 byte as maximum upload size, which is very uncommon. Did you do this on purpose? This should not be the reason behind your issue, but maybe something else is configured in such a way which could be causing this. Please let us know what your hosting company says about this.

    I activated Twenty Sixteen theme on that subsite, but the issue is still there. So I don't think Avada is doing something here. And domain mapping also should not play any role.

    Your debug data might give use some valuable insight regarding the issue. Can you turn on debug mode in WordPress? To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

    define('WP_DEBUG', true);

    In order to enable the error logging to a file on the server you need to add yet one more similar line:

    define( 'WP_DEBUG_LOG', true );

    In this case the errors will be saved to a debug.log log file inside the /wp-content/directory.

    Depending on whether you want your errors to be only logged or also displayed on the screen you should also have this line there, immediately after the line mentioned above:

    define( 'WP_DEBUG_DISPLAY', false );

    The wp-config.php is located in your WordPress root directory. It’s the same file where the database configuration settings are. You will have to access it by FTP or SFTP in order to edit it.

    Past errors here. If file is very long, paste them to a text file and attach with your reply.

    Can you please also make sure your .htaccess file has default code as suggested in "Dashboard > My Sites > Network Admin > Dashboard > Settings > Network Setup" section? Also please confirm if you have proper code added in your "wp-config.php" file as suggested on the same dashboard page?

    Please let us know these details. Also let us know what Avada and SiteGround says regarding this. I'm looking forward to hearing from you and resolving this issue as soon as possible.

    Have a nice day. Cheers!
    Rupok

  • Mark

    YOU ARE INCREDIBLE!

    Seriously. Thank you so much. That 512 value was supposed to be 512M. Changing it fixed the issue!

    I can't express how thankful I am for your help. I was afraid I was going to have to restore to a backup after a full day of work running updates.

    I'm going to go ahead and setup the WP_debug logging in my config file for future use. Also, I had been trying to set the memory limit to 768M in the php.ini file with no luck and in looking through the wp-config file, I noticed it was set there, so that issue has also been resolved.

    Thank you!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.