WordPress search function

I'm using different leveled groups to allow/disallow certain pages/posts from showing.

The WordPress search originally would only give me an "access denied" page until I added the regular expression "COMPANYURL/\?.*" to the URL group and now it at least gives me a "Nothing Found" result, even though it is not correct. What other regular expressions do I need to add to the URL group or what other setup do I need to do to get search working properly.

(I'm testing with a URL Group that has full access to the site and yet search doesn't return results I expect.)

Thanks

  • DavidM
    • DEV MAN’s Mascot

    Hi qln,

    I recall seeing an issue with search functionality and URL Groups but I'll have to see what I can find on that in the current version.

    Just to clarify, are you actually trying to restrict the search or is that simply a side effect you're experiencing from using the URL Groups you have?

    Cheers,
    David

  • DavidM
    • DEV MAN’s Mascot

    Hi qln,

    Yeah, the URL Groups might potentially restrict urls you don't want restricted, depending on how they're setup. If you're experiencing an issue with that could you maybe try switching the URL Group in question from a negative to positive rule or vice versa, to see if that helps?

    Cheers,
    David

  • DavidM
    • DEV MAN’s Mascot

    Hi qln,

    Really very sorry I seem to have missed updating this thread! If you're still experiencing issues using the URL Groups with the search feature in WordPress I'll be glad to see what I can find to assist you with this here and ask the developer to have a look here as well.

    Just to mention though, the URL Group rule itself can be placed in the positive or negative rules area. So if you can try setting them to opposite the way you had them set prior (assuming you indeed had them placed in a rule area in your member level), that'll help to sort this.

    Cheers,
    David

  • Mason
    • DEV MAN’s Sidekick

    Hiya,

    As we haven't heard back from you we're going to assume the problem was sorted out and mark this ticket as resolved.

    If it wasn't resolved, or you have any more questions related to this thread please feel free to post them below and tick the 'Mark as Not Resolved (re-open)' box below the post area (or else we'll miss it!)

    Otherwise, thanks for using the forums, and for being a member of WPMU DEV, it's a pleasure to help you out and we look forward to being of assistance in the future.

    Thanks!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.