WordPress Taxonomies becoming corrupted

I have a site which started giving some errors with the database, I think possibly some corruption in the taxonomy tables.

The tags and categories have become “disconnected” somehow. They are still there just not linked to the posts and not appearing in the admin even though the admin shows they are there somehow.

I have no idea what the problem is. Could anyone shed some light? Thanks

  • Ash
    • WordPress Hacker

    Hello nomadone

    I hope you are well today and thanks for asking the question.

    Honestly, I am not quite clear about the issue, apologize. Would you mean in front end, in every posts, categories and tags are not showed? If yes, then would you please check with your default WP 2012 theme?

    If not, would you please give some screenshots that explains a little better?

    Please let me know, I am here to help!

    Cheers

    Ash

  • nomadone
    • The Incredible Code Injector

    HI @ashok and thanks for your reply,

    It's not only a front end issue, it's a problem with the database itself.

    For example see the screenshot attached.

    In my wp-admin in the categories area it says there are a certain amount of categories but none of them show at all. The same thing happened with tags then they showed then they didn't show.

    All queries coded into the theme which rely on listing anythign taxonomy related don't run and I get errors in my error logs which contain this – "WordPress database error Got error 28"

  • nomadone
    • The Incredible Code Injector

    Thanks a ton @imperative Ideas,

    I ran that process and it seems fine now. It also seems there was some space issues with the db server not sure if that caused the problem or made it worse but all working fine now and glad to know about the repair process for future reference.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.