wordpress ubuntu version php version requirement

Hi I have the following info on phpinfo on my server for a wordpress mulituser intstall

PHP Version 5.3.3-1ubuntu9.10

I dont have a lot of knowledge about servers and php versions.

So my question is:
Is there a risk that this will stop working as new wordpress versions are released?

regards Hubbe