Wordpress Update issues with InfiniteSEO

Just updated t oWordpress 3.8 on one of my sites and have had to disable Infinite SEO plugin ... got the following php errors when trying to edit a published page...

PHP Notice: Undefined variable: robots_advanced in C:\Inetpub\vhosts\mattbrading.com\httpdocs\wp-content\plugins\wpmu-dev-seo\wds-files\wds-core\admin\wds-core-metabox.php on line 310
PHP Notice: Undefined property: stdClass::$ueid in C:\Inetpub\vhosts\mattbrading.com\httpdocs\wp-content\plugins\wpmu-dev-seo\wds-files\wds-seomoz\wds-seomoz-results.php on line 32
PHP Notice: Undefined property: stdClass::$uid in C:\Inetpub\vhosts\mattbrading.com\httpdocs\wp-content\plugins\wpmu-dev-seo\wds-files\wds-seomoz\wds-seomoz-results.php on line 36
PHP Notice: Undefined property: stdClass::$umrp in C:\Inetpub\vhosts\mattbrading.com\httpdocs\wp-content\plugins\wpmu-dev-seo\wds-files\wds-seomoz\wds-seomoz-results.php on line 40
PHP Notice: Undefined property: stdClass::$umrr in C:\Inetpub\vhosts\mattbrading.com\httpdocs\wp-content\plugins\wpmu-dev-seo\wds-files\wds-seomoz\wds-seomoz-results.php on line 40
PHP Notice: Undefined property: stdClass::$upa in C:\Inetpub\vhosts\mattbrading.com\httpdocs\wp-content\plugins\wpmu-dev-seo\wds-files\wds-seomoz\wds-seomoz-results.php on line 44

Also noticed, when I tried to use the WPMU Dashboard to tell you about it, it's not playing well with the new-look Wordpress dashboard either ... the WPMU Dashboard content is all being pushed way down the page, out of site on my main screen.

It looks like WPMU Dashboard expects the left-margin to be narrower... so the effect is a blank screen ... if that makes sense.

Hope this helps!?

Matt

  • Vinod Dalvi

    Hi @yorkey181,

    I hope you are well today.

    PHP Notice: Undefined variable: robots_advanced in C:\Inetpub\vhosts\mattbrading.com\httpdocs\wp-content\plugins\wpmu-dev-seo\wds-files\wds-core\admin\wds-core-metabox.php on line 310

    I could reproduce the above notice message and notified the developer to fix it.

    In the meanwhile to fix it, you can add the following statement in plugin file wpmu-dev-seo\wds-files\wds-core\admin\wds-core-metabox.php on line number 303

    $robots_advanced = '';

    Can you show me the screenshot of other messages and also tell me which version of InfiniteSEO plugin you are using so that i can reproduce it?

    Also noticed, when I tried to use the WPMU Dashboard to tell you about it, it's not playing well with the new-look Wordpress dashboard either ... the WPMU Dashboard content is all being pushed way down the page, out of site on my main screen.

    Can you please share me the screenshot of it?

    Best Regards,

  • Vladislav

    Hello,

    The output you're seeing aren't actually errors, they're notices and, as such, they're harmless (although very annoying and, of course, shouldn't be there in the first place). Also, the issue shouldn't be update-related, this is likely caused either by having WP_DEBUG set to true for this particular site, can you please check that and revert it to false? Having said all that, this is, of course, just an stop-gap measure - this output definitely should not be there and I'm currently working on a new release that should fix the issue.

  • yorkey181

    The WPMU Dashboard is good now, but no change to Infinite SEO sorry ...

    Seems to install OK, but when I try to edit any page I get a white screen with the following message...

    PHP Notice: Undefined index: seo_metabox_301_permission_level in C:\Inetpub\vhosts\mattbrading.com\httpdocs\wp-content\plugins\wpmu-dev-seo\wds-files\wds-core\wds-core.php on line 418

    ... and no option to continue to the editor?

    Have tried it with a different site/theme though, and that works OK so I'll disable it again for now and try a different theme on this site sometime.

    Thanks for your help!

    Matt

  • Vinod Dalvi

    Hi @yorkey181,

    As @Vladislav described in his previous reply :

    "The output you're seeing aren't actually errors, they're notices and, as such, they're harmless, this is likely caused either by having WP_DEBUG set to true for this particular site, can you please check that and revert it to false? "

    I could reproduce it on my test site therefore i have notified the develoepr to fix it.

    In the meanwhile you can just edit the following plugin file to fix it

    wpmu-dev-seo/wds-files/wds-core/wds-core.php

    On line number 418 edit the code as following

    Before Editing:
    : $wds_options['seo_metabox_301_permission_level']

    After Editing:
    : isset($wds_options['seo_metabox_301_permission_level'])? $wds_options['seo_metabox_301_permission_level']:''

    Cheers,
    Vinod Dalvi

  • yorkey181

    Thanks Vinod, but I'm not sure how you can say it's 'harmless' and not an error if it's stopping me from editing my pages? I'm really not interested in editing plugin files on multiple different websites so I'll leave it for now.

    Finding it a pain to manually update multiple different plugins on a dozen different websites each week, so I'm going to start replacing a few WPMU plugins with others that I can one-click update instead. I've got bronze membership but really can't justify another upgrade just to have the convenience most other plugin publishers provide for free... ie one click update from the wordpress dashboard.

    Anyway, thanks for your help and all the best with it.

    Matt

  • Vinod Dalvi

    Hi @yorkey181,

    Thank you for your reply and sorry for any inconvenience caused.

    Thanks Vinod, but I'm not sure how you can say it's 'harmless' and not an error if it's stopping me from editing my pages? I'm really not interested in editing plugin files on multiple different websites so I'll leave it for now.

    I have tested it on my test site setting wp-debug to true and it only displays the above Notice message but it works fine.

    There may be other plugin on your site which is stopping you from editing your pages, if you use only Infinite SEO on your any other test site setting wp-debug to true then it will definitely work without any issue.

    As explained previously the output you're seeing aren't actually errors, they're notices and, as such, they're harmless if you set wp-debug to false.

    Setting wp-debug to true on your production site is not recommended and you should only use it in development site for debugging purpose.

    Finding it a pain to manually update multiple different plugins on a dozen different websites each week, so I'm going to start replacing a few WPMU plugins with others that I can one-click update instead. I've got bronze membership but really can't justify another upgrade just to have the convenience most other plugin publishers provide for free... ie one click update from the wordpress dashboard.

    WPMU DEV also provides one-click installs and upgrades of all WPMU DEV plugins and themes, immediate access to support and the community – all from the comfort of WordPress using WPMU DEV Dashboard plugin.

    You will get more information about it on the following page.

    https://premium.wpmudev.org/project/wpmu-dev-dashboard/#usage

    Thank you for being a WPMU DEV member and have a great day!

    Any other issues, we're here to help.

    Regards,
    Vinod Dalvi

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.