WordPress User Sync Not Syncing, No Logs

WordPress User Sync isn't syncing any of my users.

I installed the plugin on two sites, and synced per the instructions. No users transferred.

I uninstalled the plugin on both sites using the red "uninstall options", re-enabled the plugin on both sites, and selected the debug option on both. After setting a main and sub site, I synced again. No users transferred.

No log file or folder exists in either sites' /plugin/user-sync directory so I have nothing to send. Thoughts?

The main site is https:// but I can't change the URL of the master site on the sub site's plugin to reflect that...is that the problem?

  • Tyler Postle

    Hey Integrant services,

    I don't believe that should be a problem.

    Can you send in the wp-admin for both sites and your FTP info? That will speed up the troubleshooting process here :slight_smile:

    You can send that privately through our contact form: https://premium.wpmudev.org/contact/

    Select "I have a different question" for your topic - this and the subject line ensure that it gets assigned to me.

    Send in:

    Subject: "Attn: Tyler Postle"
    -WordPress admin username
    -WordPress admin password
    -login url
    -FTP credentials (host/username/password)
    -link back to this thread for reference
    -any other relevant urls

    **If you keep support access active then no need to send in wp-admin

    If you do the support access method then make sure you open it for both sites :slight_smile:

    You can grant support access via WPMU DEV > Support > Support Access > Grant Support Access.

    Also, have you changed your db prefix on either of the sites by any chance?

    Look forward to hearing back!

    Cheers,
    Tyler

  • Tyler Postle

    Hey @Integrant Services,

    Thanks for granting support access! I logged in and re-connected to the master site with a https url and it looks to have worked :slight_smile:

    It looks like there is a bug when forcing https, the url of the master site should include the "s" but it doesn't; however, if you still include the https when adding the slave then it works correctly.

    I'll flag the developer so this can be fixed. In the meantime, your sync should still work.

    If you've having any further issues just let us know.

    All the best,
    Tyler

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.