WordPress Videos Tutorial Plugin

I'm getting a fatal error when I try to activate th Integrated Video Tutorials plugin. Has anyone else had this problem? Thanks.

  • James Morris
    • WordPress Enthusiast

    Hello Cori

    I hope you are well today. Thank you for your question.

    Generally speaking, if you're getting a fatal error, that means there's a conflict somewhere.

    There's a couple troubleshooting steps I'd like you to try to see if we can narrow down the cause of this problem.

    First, could you please run a plugin conflict test to eliminate the possibility of a conflict with another plugin?

    Whenever you perform a plugin conflict test, it's always better to do so on a staging site. You can learn how to create a staging site here.

    The simplest way to perform a plugin conflict test:
    * Login to your site via FTP
    * Navigate to wp-content
    * Rename the plugins folder to _plugins
    * Create a new plugins folder
    * Move the plugin folder (ex: membership) you want to test from _plugins to plugins
    * Then, one at a time, move other plugin folders over from _plugins to plugins until the symptom returns

    NOTE: While you are doing this, do not visit WP Admin -> Plugins on your site. This will ensure that your plugins remain active when you copy them back over.

    If that does not lead to a solution, could you please enable WP_DEBUG and provide us with the output of your debug.log file?

    To enable WP_DEBUG, change the following line in your wp-config.php file:

    define('WP_DEBUG', false);

    To this:

    // Enable WP_DEBUG mode
    define( 'WP_DEBUG', true );
    
    // Enable Debug logging to the /wp-content/debug.log file
    define( 'WP_DEBUG_LOG', true );
    
    // Disable display of errors and warnings
    define( 'WP_DEBUG_DISPLAY', false );
    @ini_set( 'display_errors', 0 );

    After you've visited the pages that are causing you problems, please go to wp-content/ on your server via FTP and download the debug.log file to your local computer. Then, open that file with a text editor like notepad (Windows), GEdit (Linux), or TextEdit (Mac). You can then save the file as a .txt file and upload it here as an attachment to your post.

    I look forward to seeing the results of your tests.

    Best regards,

    James Morris

  • Manuel
    • Recruit

    https://premium.wpmudev.org/profile/cori-ramos/
    This is kind of common. Has happened to me and what support told me that I can remember was basically:

    ''You need to register your domain(s)''
    (Sorry couldn't find this info to send to you a link)
    But you do this by:
    Going to the Dashboard_Admin section of your domain(s) and (from your profile) you register the videos in your Video API settings section.
    Basically you have to look at the information of your_domain.com, making sure that the name is right and if not tweak/change this information making sure it is correct.
    I hope that this helps for now.
    Manuel

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.