Wordpress vulnerability in themes

Twice yesterday from theme developers and today from my hosting company I have been sent an email about a vulnerability in wordpress. Is this something I need to worry about with any of the MU themes as I am mainly using them now?

This is a courtesy email to let you know that a security vulnerability has been discovered in a file commonly used by Wordpress theme developers. The insecure file can allow hackers to gain access to your website.

If you run any Wordpress based sites, please read through the information on the two websites below for further details and take the appropriate measures to ensure your site/sites are not at risk:

http://blog.sucuri.net/2011/08/timthumb-php-security-vulnerability-just-the-tip-of-the-iceberg.html

http://markmaunder.com/2011/zero-day-vulnerability-in-many-wordpress-themes/

If after reading the two articles above, you are unsure how to proceed, or find the advice in the articles too technical, please follow the steps below: