Working Hours are replaced by all 'Jan's

Okay, so I've tried to fix this on my own, to no avail.
I started with a stock install of the Spirit theme. No other content.
All of my Working Hours in Appointments plus are the word 'Jan'.
Things I have tried which did not work:
1. Complete deletion and reinstallation of wordpress and WPMU Dashboard and all plugins.
2. Changed theme from Spirit, back to Twenty Fifteen.
3. Changed staff User permission from Subscriber to Admin.
4. I diasabled all other plugins except the WPMU Dashboard and Appointments+.
5. I deleted the cashing the Appointments+ General settings.
So...how do I fix this?
Thanks so much!
-Dallas