Working Hours not correct on exception days

Regardless of what hours are selected for 'no specific provider' or the one other provider (me), exception days always end at 5:15pm...even though I want them to end later.

I have working hours for all options (no specific provider and all providers) set to end at 8pm on Weds/Thurs. All days are set to NO for "working?". This way I can have only a few days open using exceptions. But when I put the dates in as exceptions, the day ends at 5:15pm, regardless of whether the actual end of day in working hours is prior to or after that time. Please help.

  • Patrick

    Hi there @daisypeel

    I hope you're having a great day!

    Yep, that is confirmed on my test install also. I'm marking this as a bug and have notified the plugin developer.

    However, setting things up the opposite way does work just fine. In other words, instead of using Exceptional Working Days, use Exceptional NON Working Days.

    Set your Working Hours to Yes for the weekdays you work, regardless of the specific dates. Then block off the dates you do not work using the Exceptional NON Working Days.

    The frontend calendar then correctly reflects the working hours.

    Please let us know if this helps, and don't hesitate to post again if you need to.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.