Working hours- off by 10 minutes

I put 50 minutes as my time base, as all my dance classes are 50 minutes. However, when I try to put my working hours in, everything is off by 10 minutes, because it won't let me choose the actual time I start. (3:10pm) it will only allow me to choose 3:00pm, because it starts the 50 minute intervals at midnight. So, if people book their appointments on this plugin then they will all think their appointment starts 10 minutes earlier than it does. Is there a way to change this in the working hours? I was going to change it to 10 minute base time, but then people would be able to book at all kinds of times, and I need them booking the specific times I have set aside for classes to start, i.e. 310, 400, 450, 540, 630, 720, 810, 900, 950. Or appointments would overlap, which cannot happen. Ideas?
Thank you,
Erin

  • Tyler Postle
    • CGO

    Hey Erin,

    Welcome to the WPMU Dev community!

    I believe I have the solution for you on this one. I have posted some screenshots to illustrate. You will need to activate the Durations add-on and then go to the General settings tab and change that to "Minimum Time based Appointment Duration".

    Let me know if this solves the issue for you :slight_smile: If not, then we'll continue troubleshooting!

    Cheers,
    Tyler

  • Tyler Postle
    • CGO

    Hey Erin,

    Okay, I think now I've found a solution for you :slight_smile:

    You will want to set your working hours from 3:10 - 9:50. Then make sure your time base is set to "10" minutes and your Service duration is set to 50 minutes.

    I have attached a screenshot of the general settings just in-case.

    Hope this helps!

    Cheers,
    Tyler

  • Erin
    • New Recruit

    What you have there on the screenshot looks exactly like what I am trying to do. I will write back again if that doesn't work for some reason, otherwise, THANKS! Very excited to start using this plugin on my website. :slight_smile:

  • Erin
    • New Recruit

    Here are three screenshots. One shows the service duration as 50 minutes, one shows my time base is set at 10 minutes, and the other shows that the appointments are still able to be set every 10 minutes, not every 50 minutes like on YOUR screenshots. I must be missing one setting somewhere. Please help.

  • DavidM
    • DEV MAN’s Mascot

    Hi @Erin,

    Thanks for having sent through login details for this. I've emailed you back but also wanted to post here as well to let you know.

    I'd adjusted the duration setting to be "Service duration based calculus" as was depicted in Tyler's earlier screenshot.

    Could you let us know how that works for you?

    Thanks,
    David

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.