Working times are displayed incorrectly

On the Website, the following possible times are displayed on April 4:
09:30 free, is correct
12:00 not possible, is correct
14:30 free, is correct
17:00 not possible, is correct
19:30 not possible, this is not right.

For the service "Workshop 2,5 Std. (mind. 8 / max. 16 Personen)" there is the service provider "Workshop 2 5 Std", the working hours "Workshop 2,5 Std" Has.

According to the working hours, a booking should be possible at 19:30.

Can someone please check this and check if there is an error in the settings or in the program.

many thanks for the support.

Best regards
Support Access is active

  • Predrag Dubajic

    Hey Rainer,

    Hope you're doing well today :slight_smile:

    Thanks for granting access, I had a look at your installation and noticed that service you are referring to is 150 minutes long, but your working hours is 'till 21:00 and between 19:30 and 21:00 there's only 90 minutes so the appointment can't fit in that timeframe.

    In Appointments > Settings > General > Advance panel I've enabled "Allow Overwork" option and you can now book appointments that go over your work time.

    Is that what you're looking for?

    Best regards,

  • Predrag Dubajic

    Hi Rainer,

    Ah, so the issue here is that time is incorrect, it should show 18:30 instead of 19:30.

    That's because your times are based on the service duration and for break time it uses existing slots, since 18:30 is not there it shows 19:30 as first next available.

    What I did is enabled Tetris mode add-on and now it should be fine.

    Can you check it out and let us know if that's what you wanted?

    Best regards,

  • rainer_maechtlen

    Hi Predrag,

    yes, this is what I wanted. Thank you.

    Unfortunately I have one thing more that does not work as expected.

    The service provider "Freie Werkstatt" has the services "Free Workshop ..." and as working hours only Thursday and Saturday.
    Thursday and Saturday the booking times are displayed correctly.

    On all other days can also be booked, although the service provider "free workshop" does not work.

    How can I adjust that only on the days at which the service provider works can also be booked.

    Thanks for your support I appreciate very much.

    Best regards

  • Dimitris

    Hey there rainer_maechtlen,

    hope you're doing good today! :slight_smile:

    I just tried to navigate to page to test this service provider but page is loading very slow for me and in the end results to a error code 500.

    Could you please access your server via FTP, edit the wp-config.php file, find a line like
    define('WP_DEBUG', false);and replace it with the following (if the above line doesn’t exist, simply insert next snippet just above the /* That's all, stop editing! Happy blogging. */ comment)

    // Enable WP_DEBUG mode
    define('WP_DEBUG', true);
    // Enable Debug logging to the /wp-content/debug.log file
    define('WP_DEBUG_LOG', true);
    // Disable display of errors and warnings
    define('WP_DEBUG_DISPLAY', false);
    @ini_set('display_errors', 0);

    Then go ahead and try to replicate the error by navigating to events page ( By doing so, a /wp-content/debug.log file should be created. Simply download it, rename it to debug.txt and attach it here in your next reply. If size of text file exceeds the 5MB limit of our forums, please use a service like Dropbox and post the shareable link instead.

    Looking forward for your results!
    Take care,

  • Dimitris

    Hey there rainer_maechtlen,

    hope you're doing good today! :slight_smile:

    I inspected debug log file and noticed the following warning, which shouldn't halt any procedures, but that's not necessarily true so it worths to investigate.
    [03-Apr-2017 12:42:45 UTC] PHP Warning: include_once(): Failed opening 'shortcodes/class-app-shortcode-monthly-worker-calendar.php' for inclusion (include_path='.:/usr/local/lib/php') in /kunden/264317_73614/rp-hosting/1026/1036/wordpress/wp-content/plugins/appointments/includes/shortcodes.php on line 38
    Could you please double check that there's indeed a file like
    /plugins/appointments/includes/shortcodes/class-app-shortcode-monthly-worker-calendar.php ?

    You can also check for file permissions of your installation as described here:

    As I still can't navigate to the make an appointment page you shared, could you please try to deactivate any caches involving? Like from plugins, server side mechanisms like Varnish and/or any 3rd party services like Cloudflare.
    Let us know if that makes any difference at all!

    Finally, please grant us with support access to the website in question so we can have a better look of your setup. You can do so via WPMUDEV Dashboard plugin as described here:

    Warm regards,

  • Dimitris

    Hey there rainer_maechtlen,

    hope you're doing good today! :slight_smile:

    The icons you're seeing are coming from the connected app in your system which is assigned to open this file type. I really can't tell why this happening, maybe try to right-click on that file, select Open With -> Other, and select the "Always Open With" option before saving the app you want to open PHP files.

    Now back to your issue, I navigated to and if I choose any free service, I got calendar availability only for Thursdays and Saturdays. :thinking:
    Is this resolved or am I missing something here? Please advise!

    Warm regards,

  • rainer_maechtlen

    Hi Dimitris,

    thanks for the tipp with the icon.

    Sorry, I have no idea why it is now a step further.
    In the meantime, I moved to a separate server with my customer projects. So far these were on a shared hosting. Maybe it has to do with it.

    The performance when calling the site is extremely bad, I think there is something wrong.

    The following I get, despite many attempts, unfortunately not regulated.

    There is the service provider "free workshop" which provides the services
    "Free workshop 1 person / 2 hours"
    "Free workshop 1 person / 2.5 hrs"
    "Free workshop 1 person / 3 hours"
    "Free workshop 1 person / 3.5 hrs"

    These services each have a capacity of 16 which they share. (See image)

    Unfortunately this does not work as expected. As soon as a booking is made, no more can be made. However, 15 should still be possible.

    A service provider should provide up to 16 services at the same time.

    Your help is really appreciated.

    Best regards

  • Predrag Dubajic

    Hi Rainer,

    It looks like Tetris mode is causing slow loading times with your setup, when I export your A+ settings to my installation it blocks the loading as well, but if I try Tetris mode with clean installation it works fine.
    I'm not sure which of your settings are causing the issue with tetris mode so I will forward this issue to our second level support dev guys to have a closer look at this.

    As for the capacity issue, A+ was designed to be used as 1on1 appointment solution and capacity option is actually supposed to be used in order to reduce capacity if you have multiple providers, not to increase it.
    For having larger capacity you will need to have more providers, you can use dummy providers, or increase it with a code like this one:

    function increase_capacity( $capacity, $service_id ) {
    	return 16;
    add_filter( 'app_get_capacity', 'increase_capacity', 10, 2 );

    You can read more about this by going to Appointments > FAQ page and selecting "I want to accept more than one appointment applications for each time slot..." question.

    Best regards,

  • rainer_maechtlen

    Hello Mahlamusa,

    Thank you for asking.

    In the meantime, there were updates which unfortunately did not solve my points.
    My customer couldn't wait longer, so I contacted another solution provider.

    Unfortunately, this case was not satisfactory. I lost time and money because I could not use this plugin.

    I hope that next time will be better.

    Anyway, I would like to thank the support team, which always does his best.


    case can be closed now