WP 3.6 just came out as we all know and all the plugins

WP 3.6 just came out as we all know and all the plugins are guaranteed compatible with 3.5.2. What is the best way to move forward if I need to install a site right now and would like to use a lot of the plugins. Should I:

1) Wait until the plugins are upgraded and tested to be compatible with 3.6 and install 3.5.2 right now?

Or

2) Should I install 3.6 now?

How does the process of this normally work as I am new to this site. Thanks everyone. Excited to be here.