WP-ADMIN DIRECTORY FORWARDING TO UPGRADE.PHP

Hello, after the update to 4.6 of my site, when I try to access to the administrator, the wp-admin is redirecting to wp-admin/upgrade.php?_wp_http_referer=%2Fwp-admin%2F and the following message appears "You do not need updating" "Your WordPress database is already updated"

I already check another thread with the same title, but the solutions listed there doesn't work for me. Right now already check for the upgrade.php file, is there. I upload fresh files manually (except wp-content) and nothing. Also I try changing the plugins and theme folders names and nothing.
Thanks in advance for your help.

  • Milan

    Hello SoWo Limitada ,

    Hope you are well today and thanks for asking us. :slight_smile:

    Perform these steps one at a time and see how it goes for you. Some of them you've already followed but please follow those one more time just to be sure we are not missing anything.

    #1) Change name of /wp-content/themes folder to something else
    #2) Change name of /wp-content/plugins folder to something else.
    #3) rename your .htaccess file.
    #4) One more time download latest zip from WordPress.org and replace /wp-admin and wp-include folders with the latest ones resides in the zip.

    Let me know how it goes.
    Best Regards,
    Milan

  • Adam Czajczyk

    Hello SoWo Limitada!

    Are you using W3 Total Cache on your site? It's a common source of this issue so if it's being used and was active during the upgrade, please try following steps:

    - access the site via FTP
    - go to the "/wp-content" folder
    - rename "object-cache.php" file to e.g. "object-cache-off.php" or something similar
    - rename "advanced-cache.php" file to e.g. "advanced-cache-off.php"
    - then go to the "/wp-content/plugins" folder
    - rename only the "/w3-total-cache" folder to e.g. "/w3-total-cache-off"

    Then clear your browser's cache and try to access the site again. If it works you could rename W3 Total Cache plugin folder back to "w3-total-cache" and enable the plugin back via "Plugins -> All plugins" page.

    Let me know if it worked for you.

    Best regards,
    Adam

  • Jose Miguel

    Hello Adam, thanks for your help. I don't have W3 Total Cache installed on my site, but I was using another Cache plugin (sg-cachepress) from my WP hosting service, so I try a similar solution.
    Right now I have my wp-admin working again. I try two solutions and both works:
    1. Using Adam solution on the cache plugin you are using.
    2. After the WP update, I put a previous backup of the database and load the wp-admin. This time the wp-admin is redirected to a page asking you update the database, you press the button and voila, problem solved.
    It seems something of this type of plugins breaks the database update.

    Thanks you very much to Milan and Adam for the help.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.