/wp-admin method of logging in doesn't work

On all my subsites, I can no longer access the dashboard by using /wp-admin. For example, here is one subsite that I tried: http://kathrynlevison.com/wp-admin. Instead, I get a "404 Not Found" error message and in the address bar, I see that the browser changes the URL to:
http://kathrynlevison.com/home1/josen/public_html/wp-admin/

I already tried to contact my hosting service, and one person there renamed the .htaccess file, which caused my system to use a default .htaccess file. At that point, I then could not access any of the pages on the subsite except the home page. All other pages gave me the 404 error message.

I've seen this before, but don't know how to fix. Is it a permalink problem or caching problem? Currently, I have my WP Super Cache deactivated because it must have not been configured correctly, because it was causing havoc on all my subsites by a strange behavior: when you went to the subsite in the browser, it would trigger an immediate download of a .gz file. No subsites were working.

I'm getting overwhelmed with fixing all these issues, which may be related.

I have granted access to my account and sure could use home help.

Thanks, Joe.